bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Form renders without image-based submit button

RESOLVED WORKSFORME

Status

()

Core
Layout
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Christian Ratliff, Assigned: karnaze (gone))

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2) Gecko/20010628
BuildID:    2001071108

The form, created by the above URL, renders without the image-submit button
require to send the form. This makes the page unable to accept the form elements
and continue to the next page. The "input" object is named "Enter Now!", and
should appear below the "Remember account" checkbox.

This problem does not occurs in Mozilla 0.92 for Linux, but NOT in Mozilla 0.92
for Windows. I was able to replicate the problem in the most recent nightly
build for Linux.


Reproducible: Always
Steps to Reproduce:
1. Got to the URL listed in the ticket.
2. Try to submit the form...


Actual Results:  The form renders, but is lacking a submit button (image in this
case).

Expected Results:  Directly under the text "Remember account" a large two-tone
button should appear.

If found this originally while using Mozilla 0.92 for Linux, a FINE release if
you ask me! I fetched the nightly build from July 11, 2001 and replicated the
problem there too. When that also had a problem I tried my Windows 2000 (SP2)
machine, it worked under Mozilla 0.92 there so the problem is not generic to all
platforms.

I did validate that Mozilla could render the GIF under Linux and that it could
render the input tag in isolation. No problem in either case. That is why I
believe the problem lies in layout rather than, say, GIF processing.

-christian
cratliff@lily.org

PS. I tried to submit this bug using the "QA->Bug Template" menu item in Mozilla
0.92 for Linux. Unfortunately, after I had filled in the form elements and
clicked the submit button in the template form, I was give a totally blank page
in a new window.
I see the submit button in linux build 2001-07-09-08.   recent regression.
Keywords: regression

Comment 2

17 years ago
Changing QA contact
QA Contact: petersen → madhur

Comment 3

17 years ago
i see the image submit button under the "remember account" checkbox.
checked on build id: 2001071108 - Linux 7.1
We've had a problem with intermittently disappearing image submit buttons
before, but it just went away before we could figure it out.

Comment 5

17 years ago
wfm

Comment 6

17 years ago
The url above doesn't work today, maybe the server is down.  Anyhow, if the image 
in the button is a background image, this could be a dup of bug 91034.

Comment 7

17 years ago
WORKSFORME 2001083108 - Reopen if you can't see this fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.