All users were logged out of Bugzilla on October 13th, 2018

Support multiple-resolution OpenSearch engine icons in nsIBrowserSearchService and nsISearchEngine

RESOLVED DUPLICATE of bug 900137

Status

()

RESOLVED DUPLICATE of bug 900137
5 years ago
4 years ago

People

(Reporter: jwilde, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Over on Metro, we need the ability to support multiple sizes of higher-resolution icons for search providers.

Currently, the OpenSearch 1.1 Draft 6 spec contains a way to specify a series of search providers with different widths and heights:

  http://www.opensearch.org/Specifications/OpenSearch/1.1/Draft_3#The_.22Image.22_element

One way to implement this would be to keep the `nsISearchEngine` `iconURI` field unchanged, but add an additional `icons` field that contains a list of image objects that each have a nsIURI, numeric width, and numeric height.
This seems just like bug 900137. Mind copying your info there?
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 900137
(Assignee)

Updated

4 years ago
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.