Mozilla eats up all the systems memory!

VERIFIED DUPLICATE of bug 8646

Status

P3
normal
VERIFIED DUPLICATE of bug 8646
20 years ago
10 years ago

People

(Reporter: dejong, Assigned: morse)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
I tried to use mozilla to log into the bugzilla bug tracking
system but when I did it crashed. This crash took a long time
as it seems that mozilla was stuck in a loop allocating memory
until the system ran out of ram and swap.

(Steps)
went to bugzilla.mozilla.org
chose "Enter new Bug"
Chose "Browser"
Then it gave me a login dialog.
I typed my email addr and password.
Hit the Login button.

WHAM, got the error!


Here is the output that was printed over and over again
by mozilla until the box ran out of memory.


eading file...Done
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Reading file...
Reading file...Done
Reading file...
Virtual memory exceeded in `new'

Updated

20 years ago
Assignee: rickg → morse

Comment 1

20 years ago
Created attachment 620 [details]
stack trace for this bug
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 2

20 years ago
This is a dup of 8646 so I'm marking it as such.  However 8646 occured on viewer
only and not on apprunner.  Was the current bug observed on viewer or apprunner?

*** This bug has been marked as a duplicate of 8646 ***

Comment 3

20 years ago
I see this also, on all platforms with APPRUNNER. This seems a bit worse than
8646 but I will let you decide. To reproduce:

1. Goto http://bugzilla.mozilla.org and click on Enter a new bug report
2. Choose Browser as component
3. Enter username and password and choose to have signon saved.
4. Shutdown and re-start browser.
5. Goto http://bugzilla.mozilla.org

Results: Empty password dialogue screen comes up, which can not be dismissed.
Browser is effectively hung. Bugzilla home page is laid out in background, but
can not be accessed.

Expected Results: Bugzilla home page should be laid out and be accessible.
Password dialogue should not even come up yet, until you get to the login page.

The problem seems to be two-fold, that single-signon is being triggered even
though you are not yet at the login page, and that the password dialogue cannot
be dismissed.
(Assignee)

Comment 4

20 years ago
Paul, you are confusing two bugs here.  What you just described is bug 9041.
See me detailed description in that report of when that bug triggers.  What is
described here involves a crash (complete with stacktrace) in nsStringBundle.
So I would still like to know if anyone has seen this crash on apprunner or is
it viewer-specific.
(Reporter)

Comment 5

20 years ago
I was running viewer when I got this error.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 6

20 years ago
Marking Verified as a dup.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.