TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] caused by nsIExternalProtocolService

RESOLVED FIXED in Thunderbird 26.0

Status

MailNews Core
Testing Infrastructure
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: hiro, Assigned: hiro)

Tracking

Trunk
Thunderbird 26.0
All
Linux

Thunderbird Tracking Flags

(thunderbird24 fixed, thunderbird25 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
From https://tbpl.mozilla.org/php/getParsedLog.php?id=26350615#error3


TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
JS frame :: ../../../resources/logHelper.js :: _errorConsoleTunnel.observe :: line 63
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | (xpcshell/head.js) | exiting test
(Assignee)

Updated

4 years ago
Summary: TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] caused bynsIExternalProtocolService → TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] caused by nsIExternalProtocolService
(Assignee)

Comment 1

4 years ago
Created attachment 788787 [details] [diff] [review]
fix_for_bug903946.patch

This errors are happened in nsIExternalProtocolService.

On linux, helpers.private_mime_types_file is set to ~/.mailcap and helpers.private_mime_types_file is set to ~/.mime.types. But those files do not exist normally. 

This patch fixes errors of the following tests:

test_detachToFile.js
test_junkingWhenDisabled.js
test_mimealtdetach.js
test_partsOnDemand.js
test_hidden_attachments.js
test_attachment_size.js
Assignee: nobody → hiikezoe
Attachment #788787 - Flags: review?(mbanner)
(Assignee)

Updated

4 years ago
Blocks: 896738
Comment on attachment 788787 [details] [diff] [review]
fix_for_bug903946.patch

Looks great, thanks.
Attachment #788787 - Flags: review?(mbanner) → review+
https://hg.mozilla.org/comm-central/rev/dbfea6e6fb52
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 26.0
Comment on attachment 788787 [details] [diff] [review]
fix_for_bug903946.patch

[Triage Comment]
Taking onto branches as we'll need this there as well.
Attachment #788787 - Flags: approval-comm-beta+
Attachment #788787 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/308f4b31c056
https://hg.mozilla.org/releases/comm-beta/rev/ce0690b2a6eb
status-thunderbird24: --- → fixed
status-thunderbird25: --- → fixed
You need to log in before you can comment on or make changes to this bug.