Unfinished thimble project draft gets recovered when trying to remix another make

RESOLVED DUPLICATE of bug 913725

Status

Webmaker
Thimble
RESOLVED DUPLICATE of bug 913725
5 years ago
5 years ago

People

(Reporter: sole, Assigned: pomax)

Tracking

Details

- go to thimble.webmaker.org, creates a new blank project
- then in the same tab type in webmaker.org
- choose a thimble-based make
- click remix

Expected: it should show the source of the make we want to remix

Actual: it shows the source of the empty thimble project we started and abandoned

Updated

5 years ago
Assignee: nobody → pomax
(Assignee)

Comment 1

5 years ago
there isn't really a way to tell whether you abandoned the project, or whether you accidentally closed the browser. However, we should be able to change the way this works so that it goes "There's an old copy in your localstorage, do you want to resume that? If so, click here".
(Assignee)

Comment 2

5 years ago
I'm going to take out the "parachute" from friendlycode, so that there will be undo/redo while editing, but no autorecovery when you open thimble a second time, or after closing and reopening the browser. It's actually getting in the way more than it helps.
Status: NEW → ASSIGNED
(Assignee)

Comment 3

5 years ago
While not a true duplicate, https://bugzilla.mozilla.org/show_bug.cgi?id=913725 has to actually remove the parachute for the "new" menu option to work correctly, so this issue is implicitly folded into that work.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913725
You need to log in before you can comment on or make changes to this bug.