Closed Bug 904068 Opened 8 years ago Closed 8 years ago

Implement build/settings.py in javascript

Categories

(Firefox OS Graveyard :: Gaia, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ochameau, Assigned: yurenju)

References

Details

Attachments

(2 files)

In order to be able to build gaia with a firefox addon, we need to implement settings.py in javascript. Doing that will also match our goal to have build system to use only one language: JS.
Blocks: 904105
Attached file Pull request 11486
Do one of you feel confident reviewing this patch?

I tried to reimplement line by line python code to JS,
but devil is in the detail... so if you can give extensive time to test various configurations, that would be handy!

I worked on that as I want to make bug 904105 to work and let you guys work directly in firefox for gaia customization ASAP!
Assignee: nobody → poirot.alex
Attachment #789016 - Flags: review?(yurenju.mozilla)
Attachment #789016 - Flags: review?(timdream)
Comment on attachment 789016 [details]
Pull request 11486

looks very well for me if fixed mixing single/double quote issue and I tested it with a settings.json in GAIA_DIR/distribution/ and it works well.

great job!
Attachment #789016 - Flags: review?(yurenju.mozilla) → review+
Comment on attachment 789016 [details]
Pull request 11486

Woot!
Attachment #789016 - Flags: review?(timdream) → review+
master: f45d34aeaa35a2137cfe18aa4bee0ad91880d3bc
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
steal.
Assignee: poirot.alex → yurenju.mozilla
This PR is same as ochameau's patch but included changes of settings.[py|js] from bug 905051 and bug 896376, and re-write by commonsjs module pattern.

build error mention in commment 6 is for |make webapp-optimize| but I can't reproduce, maybe this issue is gone because bug 905096 was landed and fixed some compatibility for Windows.

I also verified this PR on Windows, works well.
Attachment #796494 - Flags: review?(timdream)
Attachment #796494 - Flags: review?(timdream) → review+
merged, thank you ochameau & Tim!
https://github.com/mozilla-b2g/gaia/commit/3ba6ef599fb1c4ea16fc6ac88bd465011ebce2a7
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
This is believed to have broken the build:
https://github.com/mozilla-b2g/gaia/commit/581ecb6b097f899896919001605699ef0b56c4c3

https://tbpl.mozilla.org/php/getParsedLog.php?id=27111057&tree=B2g-Inbound
(and yeah logs are pretty useless lol)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ok I can reproduce it, this situation only happend if you use LOCALE_BASE and LOCALES_FILE.
I have fixed this issue and landed this commit again.
https://github.com/mozilla-b2g/gaia/commit/3b6e3c02992cf16d95ddab8ecd355451dfc957bf
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Attachment mime type: text/plain → text/x-github-pull-request
You need to log in before you can comment on or make changes to this bug.