Remove restrictions to region exclusions for paid apps

RESOLVED FIXED in 2013-10-01

Status

Marketplace
Developer Pages
P2
normal
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: scolville, Assigned: scolville)

Tracking

2013-10-01
x86
Mac OS X
Points:
---
Dependency tree / graph

Details

(Whiteboard: qa++)

Currently we are restricting region exclusions for paid apps down to regions that are relevant to the price point selected.

This causes problems.

For example if payments are turned off for a region temporarily the user could currently go into devhub save the payment details and then create an exclusion record for that region. Once it's re-enabled they would then have their app excluded even if they didn't previously.

The solution is to show all regions regardless (possibly separated by those that have payments and those that don't)

If payments are not available for the price point, this will be shown in the UI. 

Always the developer will be able to set *any* of the regions for paid apps. This then de-couples regions (as relate to addonExcludedRegion records) from price region data.
This doesn't seem like a high priority, but interested in your input.  What's the priority/status?
Priority: -- → P4
This is necessary to prevent a lot of pain in terms of managing the relationship between region exclusions for the apps as well as regions for payments.

Whilst the immediate impact to end-users is not much presently getting this done sooner rather than later is preferable and the fix is already quite fair along. So I'd put this as more a p3 for that reason.
Priority: P4 → P3
Target Milestone: --- → 2013-09-10
Depends on: 913105
Depends on: 913123
Target Milestone: 2013-09-10 → 2013-09-17
Making this P2 as per the dep bugs.
Depends on: 913546
Priority: P3 → P2
Removing the milestone due to the deps. I'll keep this branch up to date so it doesn't bit-rot for when we are ready.
Target Milestone: 2013-09-17 → ---
Depends on: 909532
Still needs reworking animations over to transitions.
Status: NEW → ASSIGNED
Duplicate of this bug: 921186
(In reply to Stuart Colville [:scolville] from comment #5)
> Still needs reworking animations over to transitions.

Going to look at this separately.
Target Milestone: --- → 2013-10-01
https://github.com/mozilla/zamboni/commit/1bb5a3816b34728487686721cee6775fe4d76d63
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Extra QA Notes:

This changes a lot of code around the devhub for region selection for both free and paid apps. Please make sure everything is working as expected.

Suggested areas to check (but not limited to):

* App region selection.
* Conversion between free and paid apps.
* Enable new regions checkbox.
* Selection of prices (see the animations of checkboxes so the user knows which apps are associated with which regions).

This de-restricts region choices for paid so checking how this is displayed (code to filter apps in search has already landed separately).
Whiteboard: qa++
You need to log in before you can comment on or make changes to this bug.