Last Comment Bug 904162 - Permanent Orange (windows): TEST-UNEXPECTED-FAIL | test_partsOnDemand.js | test_attachment_size.js | uncaught exception: 2147500037
: Permanent Orange (windows): TEST-UNEXPECTED-FAIL | test_partsOnDemand.js | te...
Status: RESOLVED FIXED
: intermittent-failure
Product: MailNews Core
Classification: Components
Component: Testing Infrastructure (show other bugs)
: Trunk
: All Windows 7
: -- normal (vote)
: Thunderbird 26.0
Assigned To: Hiroyuki Ikezoe (:hiro)
:
Mentors:
Depends on:
Blocks: 896738
  Show dependency treegraph
 
Reported: 2013-08-12 11:56 PDT by Mark Banner (:standard8)
Modified: 2013-08-27 11:07 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Remove_file_extension_to_avoid_test_orange_on_windows.patch (2.66 KB, patch)
2013-08-20 01:20 PDT, Hiroyuki Ikezoe (:hiro)
no flags Details | Diff | Review
[checked in] Remove_file_extension_to_avoid_test_orange_on_windows.patch (2.10 KB, patch)
2013-08-20 01:22 PDT, Hiroyuki Ikezoe (:hiro)
standard8: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review
Possible fix for test_partsOnDemand.js (861 bytes, patch)
2013-08-20 01:34 PDT, Hiroyuki Ikezoe (:hiro)
standard8: review+
standard8: approval‑comm‑aurora+
standard8: approval‑comm‑beta+
Details | Diff | Review

Description Mark Banner (:standard8) 2013-08-12 11:56:51 PDT
Windows-only bug, currently seen on Beta on tbpl, probably other branches as well:

https://tbpl.mozilla.org/php/getParsedLog.php?id=26442386&tree=Thunderbird-Beta#error21

TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
JS frame :: ../../../resources/logHelper.js :: _errorConsoleTunnel.observe :: line 63
native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0

TEST-INFO | (xpcshell/head.js) | exiting test
Comment 1 Treeherder Robot 2013-08-12 14:51:51 PDT
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=26451149&tree=Thunderbird-Beta
TB Rev3 WINNT 5.1 comm-beta opt test xpcshell on 2013-08-12 13:41:54
revision: 7f9f2db26a67
slave: talos-r3-xp-108

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | Test timed out
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | test failed (with xpcshell return code: 1), see following log:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_offline.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online_to_offline.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Only displaying first 20 of 21 failures -
.
Comment 2 Treeherder Robot 2013-08-12 15:18:05 PDT
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=26452012&tree=Thunderbird-Beta
TB Rev3 WINNT 6.1 comm-beta opt test xpcshell on 2013-08-12 13:42:00
revision: 7f9f2db26a67
slave: talos-r3-w7-095

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | Test timed out
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | test failed (with xpcshell return code: 1), see following log:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_offline.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online_to_offline.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Only displaying first 20 of 21 failures -
.
Comment 3 Hiroyuki Ikezoe (:hiro) 2013-08-12 16:34:00 PDT
I am guessing the cause of this error is similar to bug 903946, it is in mozilla/uriloader/exthandler/win/nsOSHelperAppService.cpp.

Is there someone using Windows?
Comment 4 Treeherder Robot 2013-08-12 23:55:13 PDT
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=26454132&tree=Thunderbird-Beta
TB Rev3 WINNT 6.1 comm-beta debug test xpcshell on 2013-08-12 14:04:04
revision: 7f9f2db26a67
slave: talos-r3-w7-124

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | Test timed out
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\chat\modules\test\test_filtering.js | test failed (with xpcshell return code: 1), see following log:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_offline.js | test failed (with xpcshell return code: -2147483645), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_offline.js | application crashed [@ mozalloc_abort(char const * const)]
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online.js | test failed (with xpcshell return code: -2147483645), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online.js | application crashed [@ mozalloc_abort(char const * const)]
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online_to_offline.js | test failed (with xpcshell return code: -2147483645), see following log:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../../resources/logHelper.js | Error console says [stackFrame Component returned failure code: 0x80550007 [nsIMsgFolder.getStringProperty]] - See following stack:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\mailnews\db\gloda\test\unit\test_index_messages_imap_online_to_offline.js | application crashed [@ mozalloc_abort(char const * const)]
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | test failed (with xpcshell return code: -2147483645), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | application crashed [@ mozalloc_abort(char const * const)]
Only displaying first 20 of 25 failures -
.
Comment 5 Hiroyuki Ikezoe (:hiro) 2013-08-20 01:20:25 PDT
Created attachment 792675 [details] [diff] [review]
Remove_file_extension_to_avoid_test_orange_on_windows.patch

This is a patch for the failure of test_attachment_size.js

On my enviroment test_partsOnDemand.js does not fail unfortunately.
Comment 6 Hiroyuki Ikezoe (:hiro) 2013-08-20 01:22:16 PDT
Created attachment 792678 [details] [diff] [review]
[checked in] Remove_file_extension_to_avoid_test_orange_on_windows.patch

The previous patch was wrong one....
Comment 7 Hiroyuki Ikezoe (:hiro) 2013-08-20 01:34:40 PDT
Created attachment 792683 [details] [diff] [review]
Possible fix for test_partsOnDemand.js

I am not really convinced, but this patch might solve the failure of test_partsOnDemand.js. I hope!
Comment 8 Hiroyuki Ikezoe (:hiro) 2013-08-20 01:45:20 PDT
Archaeopteryx, could you please push both two patches on try server with "-p all -u xpcshell -t none" options.

Thank you,
Comment 9 Sebastian H. [:aryx][:archaeopteryx] 2013-08-20 03:55:53 PDT
Pushed the patches to Thunderbird-Try a hour ago, should be finished in two hours: https://tbpl.mozilla.org/?tree=Thunderbird-Try&showall=1&rev=b35523ae644e
Comment 10 Hiroyuki Ikezoe (:hiro) 2013-08-20 14:41:15 PDT
Thank you, Archaeopteryx. But try server has still problems unfortunately.
Comment 11 Treeherder Robot 2013-08-22 10:39:34 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26876431&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-22 08:39:32
revision: 8e9531bfd45a
slave: t-w732-ix-080

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 12 Treeherder Robot 2013-08-22 11:27:07 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26878594&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-22 09:34:37
revision: 8e9531bfd45a
slave: t-w732-ix-078

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 13 Treeherder Robot 2013-08-22 15:13:39 PDT
jcranmer
https://tbpl.mozilla.org/php/getParsedLog.php?id=26890744&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-22 13:39:13
revision: 339bc9eac2fc
slave: t-w732-ix-068

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 14 Treeherder Robot 2013-08-23 08:44:57 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26924568&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-23 08:07:12
revision: dd169329db9d
slave: t-xp32-ix-053

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 15 Treeherder Robot 2013-08-23 09:05:27 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26924819&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-23 08:20:03
revision: dd169329db9d
slave: t-xp32-ix-093

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 16 Treeherder Robot 2013-08-23 09:10:46 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26925162&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-23 08:20:03
revision: dd169329db9d
slave: t-w732-ix-060

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 17 Treeherder Robot 2013-08-23 09:42:34 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26925814&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-23 08:28:03
revision: dd169329db9d
slave: t-w732-ix-050

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - see following stack:
Comment 18 Treeherder Robot 2013-08-26 05:06:35 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26979220&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-25 04:29:58
revision: 51d7c81f566c
slave: t-w732-ix-104

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 19 Treeherder Robot 2013-08-26 05:06:37 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26979057&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-25 04:29:57
revision: 51d7c81f566c
slave: t-xp32-ix-121

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 20 Treeherder Robot 2013-08-26 05:08:56 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26988392&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-25 18:55:15
revision: a451602b2973
slave: t-xp32-ix-015

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 21 Treeherder Robot 2013-08-26 05:09:05 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26988437&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central debug test xpcshell on 2013-08-25 18:55:47
revision: a451602b2973
slave: t-xp32-ix-033

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\toolkit\components\jsdownloads\test\unit\test_DownloadCore.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | resource://gre/modules/commonjs/sdk/core/promise.js | Unexpected exception NS_ERROR_PORT_ACCESS_NOT_ALLOWED: Component returned failure code: 0x804b0013 (NS_ERROR_PORT_ACCESS_NOT_ALLOWED) [nsIChannel.asyncOpen]
Comment 22 Treeherder Robot 2013-08-26 05:09:14 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26988471&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-25 18:55:14
revision: a451602b2973
slave: t-w732-ix-104

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 23 Treeherder Robot 2013-08-26 05:09:17 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=26988596&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-25 18:55:48
revision: a451602b2973
slave: t-w732-ix-014

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 24 Treeherder Robot 2013-08-26 07:08:13 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27002194&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-26 06:31:48
revision: a451602b2973
slave: t-xp32-ix-007

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 25 Treeherder Robot 2013-08-26 07:24:37 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27002585&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-26 06:31:46
revision: a451602b2973
slave: t-w732-ix-052

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 26 Treeherder Robot 2013-08-26 08:39:28 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27005041&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-26 07:53:57
revision: 4c2345e03ee4
slave: t-xp32-ix-056

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 27 Treeherder Robot 2013-08-26 09:07:43 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27005705&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central debug test xpcshell on 2013-08-26 08:00:49
revision: 4c2345e03ee4
slave: t-xp32-ix-104

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\toolkit\components\jsdownloads\test\unit\test_DownloadCore.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | resource://gre/modules/commonjs/sdk/core/promise.js | Unexpected exception NS_ERROR_PORT_ACCESS_NOT_ALLOWED: Component returned failure code: 0x804b0013 (NS_ERROR_PORT_ACCESS_NOT_ALLOWED) [nsIChannel.asyncOpen]
Comment 28 Treeherder Robot 2013-08-26 09:07:49 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27005780&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-26 07:53:46
revision: 4c2345e03ee4
slave: t-w732-ix-047

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 29 Treeherder Robot 2013-08-26 09:07:52 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27006492&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central debug test xpcshell on 2013-08-26 08:01:47
revision: 4c2345e03ee4
slave: t-w732-ix-130

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 30 Treeherder Robot 2013-08-26 09:57:23 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27008839&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-26 09:25:45
revision: 4c2345e03ee4
slave: t-xp32-ix-123

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 31 Treeherder Robot 2013-08-26 10:28:56 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27009586&tree=Thunderbird-Trunk
TB Windows 7 32-bit comm-central opt test xpcshell on 2013-08-26 09:25:45
revision: 4c2345e03ee4
slave: t-w732-ix-030

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 32 Mark Banner (:standard8) 2013-08-27 00:32:18 PDT
Comment on attachment 792678 [details] [diff] [review]
[checked in] Remove_file_extension_to_avoid_test_orange_on_windows.patch

Looks good, thanks. r=Standard8.
Comment 33 Mark Banner (:standard8) 2013-08-27 00:50:14 PDT
Comment on attachment 792678 [details] [diff] [review]
[checked in] Remove_file_extension_to_avoid_test_orange_on_windows.patch

[Triage Comment]
Taking straight onto aurora/beta as I know this fixes the issues there.
Comment 35 Treeherder Robot 2013-08-27 05:08:24 PDT
RyanVM
https://tbpl.mozilla.org/php/getParsedLog.php?id=27056643&tree=Thunderbird-Trunk
TB Windows XP 32-bit comm-central opt test xpcshell on 2013-08-27 04:18:51
revision: 4c2345e03ee4
slave: t-xp32-ix-034

TEST-UNEXPECTED-FAIL | C:\slave\test\build\xpcshell\tests\mailnews\mime\test\unit\test_attachment_size.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
Comment 36 Treeherder Robot 2013-08-27 06:25:40 PDT
Standard8
https://tbpl.mozilla.org/php/getParsedLog.php?id=27058731&tree=Thunderbird-Beta
TB Rev3 WINNT 5.1 comm-beta debug test xpcshell on 2013-08-27 04:28:38
revision: 2f265533662b
slave: talos-r3-xp-132

TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\base\test\unit\test_compactFailure.js | test failed (with xpcshell return code: 0), see following log:
TEST-UNEXPECTED-FAIL | C:/talos-slave/test/build/xpcshell/tests/mailnews/base/test/unit/test_compactFailure.js:112 | ReferenceError: loadLocalMailAccount is not defined - See following stack:
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | test failed (with xpcshell return code: -2147483645), see following log:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
TEST-UNEXPECTED-FAIL | ../../../resources/logHelper.js | Error console says [stackFrame uncaught exception: 2147500037] - See following stack:
PROCESS-CRASH | C:\talos-slave\test\build\xpcshell\tests\mailnews\imap\test\unit\test_partsOnDemand.js | application crashed [@ mozalloc_abort(char const * const)]
Comment 37 Mark Banner (:standard8) 2013-08-27 10:16:04 PDT
Comment on attachment 792683 [details] [diff] [review]
Possible fix for test_partsOnDemand.js

Ok, try server says this works for comm-beta. I'm going to assume there's some difference in the builders that we've got on central versus beta, but as this passes, I think its fine to take it everywhere, as it'll possibly solve failures for developers as well.
Comment 38 Mark Banner (:standard8) 2013-08-27 10:22:16 PDT
https://hg.mozilla.org/comm-central/rev/c0baf3d087a3

Note You need to log in before you can comment on or make changes to this bug.