Firefox tries to download (rather than display) a PDF when restoring tabs

RESOLVED DUPLICATE of bug 901294

Status

()

--
major
RESOLVED DUPLICATE of bug 901294
5 years ago
5 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Using Firefox nightly on Mac,

1. mkdir -p ~/px/fff
2. firefox -profile ~/px/fff/
3. Load a PDF that triggers pdf.js and crashes.
4. firefox -profile ~/px/fff/

Expected:
  1st try: restore PDF
  2nd try: "select tabs to restore"
  3rd try: safe mode

Result:
  Firefox decides to DOWNLOAD the pdf, while showing either the home page or the "select tabs to restore" page.

Not sure if this is more of a session restore bug or a PDF viewer bug.
(Reporter)

Comment 1

5 years ago
I tested using the crashing PDF in bug 903722.  That crash is Mac-only and also triggers bug 717758 and bug 904276.

Comment 2

5 years ago
most likely bug 901294

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 901294
You need to log in before you can comment on or make changes to this bug.