Status

()

Core
DOM
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: martin.honnen, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] TH.cellIndex returning negative val)

Attachments

(3 attachments)

(Reporter)

Description

19 years ago
Accessing the
  cellIndex
property of a TH element shows
  -1
while TD shows the expected value; Example

<HTML>
<HEAD>
</HEAD>
<BODY>
<TABLE>
<THEAD>
<TR>
<TH ONCLICK="alert(this.cellIndex);">
Name
</TD>
</TR>
</THEAD>
<TBODY>
<TR>
<TD ONCLICK="alert(this.cellIndex);">
Kibo
</TD>
</TR>
</TBODY>
</TABLE>
</BODY>
</HTML>

Updated

19 years ago
QA Contact: gerardok → janc
(Reporter)

Comment 1

19 years ago
Created attachment 735 [details]
bug demonstration

Comment 2

19 years ago
Created attachment 1118 [details]
Previous example had an error on the element in question <TH>..</TD>

Updated

19 years ago
Whiteboard: [TESTCASE] TH.cellIndex returning negative val

Comment 3

19 years ago
The first attachment also likes to create lots of extra windows on the screen.
The new one displays the value in an <INPUT> field.

Oh, and the <TH> element still returns -1. 19990802 M9 build on Win98.
What seems to happen is:
 * TH.cellIndex is always -1
 * TD.cellIndex is the number of TD (but not TH) elements that occurred earlier
in the row.

Attaching additional testcase (based on previous).

Should this go to karnaze?
Created attachment 1423 [details]
Additional testcase

Updated

19 years ago
Assignee: vidur → karnaze

Comment 6

19 years ago
David's right - this should go to karnaze (especially since he's less doomed
than I am :-).
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

19 years ago
Fixed with 9/8/99 checkin.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
confirmed
marking verified
You need to log in before you can comment on or make changes to this bug.