[JavaScript Warning: "ReferenceError: reference to undefined property Cc['@mozilla.org/updates/update-prompt;1']" {file: "chrome://browser/content/shell.js" line: 1101}]

RESOLVED DUPLICATE of bug 904462

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 904462
5 years ago
5 years ago

People

(Reporter: kanru, Assigned: mtseng)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Where is @mozilla.org/updates/update-prompt;1? Do we use that?
UpdatePrompt is only defined in production build or eng build with B2G_UPDATER=1.
Checking the existence of Cc["@mozilla.org/updates/update-prompt;1"] before invoking createInstance() should avoid this JS error.

http://dxr.mozilla.org/mozilla-central/source/b2g/components/B2GComponents.manifest#l15
Created attachment 790613 [details] [diff] [review]
bug904505-jserror

add code for checking existance bofore using it
Attachment #790613 - Flags: review?(fabrice)

Updated

5 years ago
Assignee: nobody → mtseng
that is fixed in bug 904462
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 904462
Attachment #790613 - Flags: review?(fabrice)
You need to log in before you can comment on or make changes to this bug.