Thimble Makes published before June 15th display 404 error

RESOLVED FIXED

Status

Webmaker
Make Valet
--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: epilepticrabbit, Assigned: jbuck)

Tracking

Details

(Reporter)

Description

5 years ago
These Mozteach makes are shooting 404s, and they aren't in the MakeAPI. Did someone delete these makes?

https://mozteach.makes.org/thimble/webmaker-activity-template
https://mozteach.makes.org/thimble/teaching-kit-template
https://mozteach.makes.org/thimble/thimble-kit
http://mozteach.makes.org/thimble/hackable-resource-template

This one: https://mozteach.makes.org/thimble/teaching-kit-template is the most important - it's the only updated code + content version of this. Can we restore it?
This might be related to the new makes.org server... cc-ing jbuck for thoughts.
(Assignee)

Comment 2

5 years ago
Laura, for that last make you can use https://mozteach.makes.org/thimble/hackable-resource-template and it'll load (https vs http, related to bug 903604)

For the first three they will need to be republished, but you can get the source code from:
http://makes.org.s3-website-us-east-1.amazonaws.com/mozteach/thimble/webmaker-activity-template (will need some editing)
http://makes.org.s3-website-us-east-1.amazonaws.com/mozteach/thimble/teaching-kit-template_
http://makes.org.s3-website-us-east-1.amazonaws.com/mozteach/thimble/thimble-kit (will need some editing)
jbuck: noticing some other 404s from the /teach page:
https://nwp.makes.org/thimble/coding-with-the-times-kit

* is there a fix coming for this? or do we need partners like NWP to re-publish or do something? Have we lost data?
Summary: Specific Mozteach Makes disappeared → Some teaching kit links on /teach page are broken
(Reporter)

Comment 4

5 years ago
not just /teach. Two of our three event guides are 404ing, 

https://webmaker.makes.org/thimble/host-a-hack-jam
https://webmaker.makes.org/thimble/host-a-hive-popup

Doesn't have anything to do with http vs https, I've tried both.

This means that user makes are probably disappearing too?
Severity: normal → major
Summary: Some teaching kit links on /teach page are broken → Links to Makes from all over the site are broken
(Assignee)

Comment 5

5 years ago
So, it looks like makes published before Friday June 14th have problem where the make details bar was published with the make, so no _ version of the file exists, which the make-valet expects to exist.

Here's a list of makes on /teach that I've edited to work again:
* https://mozteach.makes.org/thimble/hackable-goals-template
* https://mozteach.makes.org/thimble/hackable-activity-template
* https://mozteach.makes.org/thimble/hackable-profile-template
* https://mozteach.makes.org/thimble/webmaker-activity-template
* https://mozteach.makes.org/thimble/thimble-kit
* https://nwp.makes.org/thimble/coding-with-the-times-kit
* https://nwp.makes.org/thimble/making-stopmotion-movies
* https://webmaker.makes.org/thimble/host-your-own-hive-popup
* https://webmaker.makes.org/thimble/host-a-hackjam

Here's a list of pages that don't exist in the MakeAPI, and will need to be republished:
* https://mozteach.makes.org/thimble/teaching-kit-template but you can get the source code from http://makes.org.s3-website-us-east-1.amazonaws.com/mozteach/thimble/teaching-kit-template_

Should I go through all of the @mozteach, @nwp, and @webmaker makes to ensure they work? Or are these high priority ones enough?
Assignee: nobody → jon
Status: NEW → ASSIGNED
Component: webmaker.org → Make Valet
(Assignee)

Updated

5 years ago
Summary: Links to Makes from all over the site are broken → Thimble Makes published before June 15th display 404 error
@ Jbuck thanks for doing this, Jbuck!

* We're still having issues with 404s for Thimble for *new* makes as well

* For example: Erika K published this five minutes ago: https://smallbutmighty.makes.org/thimble

* But it is throwing up a 404

* Wanted to report this in case something we pushed recently is breaking Thimble in general -- instead of just for makes created before June 14, as per your comment 5
* JBuck just confirmed this was a URL truncation issue -- so no worries!
Need this one, too, please:
https://nwp.makes.org/thimble/coding-with-the-times-goals

@ JBuck: let us know if there's a way for us to fix or retrieve this ourselves?

* Also: we are constraining ourselves here to include broken links that are a high priority for the work week.
@ Jbuck: it would be great to have these fixed before the 4:30 demo slot today, if possible. pretty please? :) the teaching kits group has demo envy!
(Assignee)

Comment 13

5 years ago
Alright, I've run through all of the nwp makes and confirmed that they're all working now.

Erika: use https for popcorn.webmadecontent.org links so that it'll work in newer versions of Chrome and Firefox:
https://popcorn.webmadecontent.org/138b
https://popcorn.webmadecontent.org/138g

Matt: for http://webmaker.makes.org/thimble/host-a-hack-jam use https://webmaker.makes.org/thimble/host-a-hackjam instead. The link you gave doesn't exist anymore, it's been deleted. It could be recreated by someone who has access to the webmaker account though...
(Assignee)

Updated

5 years ago
Duplicate of this bug: 905681
(Assignee)

Comment 16

5 years ago
I just worked with kat to republish all of the @webmaker makes, and fixed the last @mozteach make that wasn't working.

Gonna call this bug closed, but reopen if you find any more!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Yo, re-opening this because a colleague found *more* 404 errors today, this time on the frontpage: https://bugzilla.mozilla.org/show_bug.cgi?id=907646

These are new 404s, happening on the 'flip' on Webmaker homepage when you try to go to Thimble or Popcorn... 

:*( #sadface
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 18

5 years ago
We're having trouble here too: https://bugzilla.mozilla.org/show_bug.cgi?id=884224

hack jam and popup event guides both hit 404s. Bug 8842224 summarizes the issue - I wasn't sure WHICH bug to reopen, so we reopened both :P
Adding to Laura's point, this bug also covers error messages on teach guides: https://bugzilla.mozilla.org/show_bug.cgi?id=896390

So many bugs!
(Assignee)

Comment 20

5 years ago
Looks like both of those bugs are different from this one so I'm closing this one again
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.