Add social sharing links to event detail pages

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: hoosteeno, Assigned: agibson)

Tracking

Details

(Whiteboard: [kb=1076572] [q3 events])

Attachments

(1 attachment)

Created attachment 789570 [details]
remo_share_suggested_implementation.jpg

To make events easier to share, let's add sharing buttons to the event detail page (ex: https://reps.mozilla.org/e/basej-js-introduction-to-firefox-os/).

Let's use direct links to external networks, rather than embedded js/iframes:

    Facebook: https://www.facebook.com/sharer/sharer.php?u=REMO_URL

    Twitter: http://twitter.com/share?url=REMO_URL&via=mozillareps&text=PAGE_TITLE

    Google+: https://plus.google.com/share?url=REMO_URL&hl=en-US

A rough proposed UI is attached. Please suggest alternatives if this is not the right UI. Please modify as needed to satisfy implementation constraints.
Whiteboard: [kb=1076572]
(Assignee)

Comment 1

4 years ago
For privacy reasons, should we be using Mozilla's SocialShare widget for this feature?

https://github.com/mozilla/socialshare
The socialshare widget prevents leaking personal details from Mozilla web properties without user consent. So do the links suggested above -- they're just URLs on the page.
(Assignee)

Comment 3

4 years ago
Ah sorry, my eyes missed the part that mentioned using direct links the first time I read it :)
Depends on: 904608
Note about implementation: I didn't intend the attached mockup to be replicated in pixel perfection. The icons could be better, for example. I believe we can use any FOSS social icon set that we like. I think the ones on Flicks look pretty good; if there are no objections, I suggest we just use these: 

https://firefoxflicks.mozilla.org/static/img/social-icons.png

:agibson, is this enough to get started, or would you like a mockup that includes all of these elements?
Flags: needinfo?(agibson)
(In reply to Justin Crawford [:hoosteeno] from comment #4)
> Note about implementation: I didn't intend the attached mockup to be
> replicated in pixel perfection. The icons could be better, for example. I
> believe we can use any FOSS social icon set that we like. I think the ones
> on Flicks look pretty good; if there are no objections, I suggest we just
> use these: 
> 
> https://firefoxflicks.mozilla.org/static/img/social-icons.png

I also like these icons for Facebook and Twitter, though we also need a Google+ icon. I'm also happy using the logo icons mocked up in comment 0. I don't have a strong preference between the two styles.
(Assignee)

Comment 6

4 years ago
(In reply to Justin Crawford [:hoosteeno] from comment #4)
> :agibson, is this enough to get started, or would you like a mockup that
> includes all of these elements?

Thanks Justin, 

This should be enough to get started. I'll see if I can source where these icons came from originally. If they're from an open source set, there may well already be a Google+ icon. If not, I'll look to make one that matches.
Flags: needinfo?(agibson)
(Assignee)

Comment 7

4 years ago
PR here:

https://github.com/mozilla/remo/pull/456
(Assignee)

Updated

4 years ago
Assignee: nobody → agibson
Whiteboard: [kb=1076572] → [kb=1076572] [q3 events]

Comment 8

4 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/34016d32e24b263f1d0d97a78acdc9ac17db2e80
[fix bug 904601] Add social sharing links to event detail pages

https://github.com/mozilla/remo/commit/e008d4e8d4a34c264c162b4edffdf701c42c6ed3
Merge pull request #456 from alexgibson/bug-904601-add-social-sharing-links-event-detail-pages

[fix bug 904601] Add social sharing links to event detail pages

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Verified on dev able to share events on Google+ & Twitter. Unable to share on Facebook, filed bug 907231
Depends on: 907231
Duplicate of this bug: 851038
Closing as 'Verified fixed' as per comment 9. Facebook to be verified in bug 907231.

Thanks Rebecca!
Status: RESOLVED → VERIFIED
Version: unspecified → 411
You need to log in before you can comment on or make changes to this bug.