Image removed when onMouseOver should show other image...

VERIFIED FIXED

Status

()

Core
Event Handling
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: cpratt, Assigned: joki (gone))

Tracking

({platform-parity})

Trunk
x86
Windows NT
platform-parity
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh:need to check how events react with alt texts), URL)

(Reporter)

Description

19 years ago
Build ID: 1999062908
Platform: Windows NT, Linux

To reproduce:

- Load the above URL (the one at schist has a simpler test case)
- Note that when you mouse over one of the buttons (pictures, links, rooms,
etc.) the image goes away and instead the alt text is displayed instead
Basically, when the page is first loaded, an image is (correctly) displayed. The
sample HTML in this bug report shows that rooms02.gif should be loaded and
displayed, which happens correctly. However, when the button receives the focus,
the image should be replaced by rooms03.gif - but that isn't happening. When the
button loses the focus, the image should revert to rooms02.gif, but instead the
ALT tag remains displayed in the browser.

[begin sample HTML]

<!--
if (document.images)
             {
                roomson = new Image(80,25);
                roomson.src = "rooms03.gif";

                roomsoff = new Image(80,25);
                roomsoff.src = "rooms02.gif";
             }
// -->
</SCRIPT>



<A HREF="rooms.htm" target="tekst"
                onMouseover='img_act("rooms"),window.status = "information about
our rooms"; return true'
                onMouseout='img_inact("rooms"),window.status =
window.defaultStatus;return true'><IMG
                SRC='rooms02.gif'
                ALT='information about our rooms'
                WIDTH='80'
                HEIGHT='25'
                BORDER='0'
                NAME='rooms'></A><br>
(Reporter)

Updated

19 years ago
QA Contact: petersen → phillip

Updated

19 years ago
Summary: Image removed when onMouseOver should show other image... → [PP]Image removed when onMouseOver should show other image...

Comment 1

19 years ago
"events03.gif", "loc03.gif", "prices03.gif", and "reserva03.gif" somehow do
not show up on 4.7 either on windows nt or linux.

so there is a difference between how 4.7 handles this page ( no image swapping
on mouseover) and how seamonkey does (swapping to some bogus image, and never
again showing the original image).

what is the correct behavior?
(Reporter)

Comment 2

19 years ago
weird, weird, weird. Using IE 5 and Communicator 4.61 under NT, what happens is
the that *03.gif files are displayed when the button gains focus, and the
*02.gif files are displayed when the button loses focus. That, I believe, is
correct behavior. Seamonkey/Apprunner are not displaying the *03.gif files,
substituting the ALT tag text, and never reverting to the original image.

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
*** Bug 10032 has been marked as a duplicate of this bug. ***
Whiteboard: (py8ieh:need to check how events react with alt texts)
It appears there is a side issue dealing with how alt texts cope with events -
maybe the alt text is not bubbling the mouse-out correctly. I will investigate
this at some point; I believe another bug is already covering this issue. It is
probably related to similar problems with generated content.

Updated

19 years ago
Assignee: beard → joki
Status: ASSIGNED → NEW
Component: Compositor → Event Handling

Updated

19 years ago
QA Contact: phillip → janc

Updated

19 years ago
Keywords: pp

Updated

19 years ago
Summary: [PP]Image removed when onMouseOver should show other image... → Image removed when onMouseOver should show other image...

Comment 5

19 years ago
Images are correctly changed (displayed) here with:
- win98/2000022908
- linux/2000022909

Comment 6

19 years ago
I had checked in a fix for this bug a while back.  Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 7

18 years ago
Mass update:  changing qacontact to ckritzer@netscape.com
QA Contact: janc → ckritzer

Comment 8

18 years ago
Updating QA Contact.
QA Contact: ckritzer → lorca
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 10

17 years ago
QA contact updated
QA Contact: gerardok → madhur

Comment 11

17 years ago
verified on build 2001-07-30-03-trunk
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.