All users were logged out of Bugzilla on October 13th, 2018

[Session Restore] jank immediately upon opening new tab (from Thunderbird)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: wsmwk, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
+++ This bug was initially created as a clone of Bug #506975 +++

on my vista laptop frequently (>50% ?) I open a new tab via thunderbird and immediately sessionstore.js is being written (at least, I assume it is based on file timestamp. I see jank immediately - locking firefox, and delayed tab display - until sesssionstore is done writing.

I'm filing this unconfirmed for several reasons, including 
- I'm filing this is partly on impression (but I think the odds of opening a URL and hitting the sessioninterval "expiration" aren't as high as 50%)
- I haven't fully tested this
- I'm not able to reproduce on my desktop

So notes:
- I haven't instrumented this
- vista laptop, 5400rpm disk, firefox nightly build
- sessionstore.js currently 24MB
- browser.sessionstore.interval customized at 20000
- I don't know the design/algorithm for deciding when sessionstore.js gets written - is it strictly at end of sessionstore.js time interval?
- if there is not a bug, perhaps there should be an explicit delay between opening a tab and session save, so one can at least view the page?
Whiteboard: [battery][good first bug][mentor=ttaubert][lang=js]
I'm sure we don't save when opening an external link. We will schedule a delayed save when the newly opened tab has finished loading. If you happen to invalidate the state shortly before opening an external link then there's a good chance the we save state right after or shortly before the external link is opened. This can definitely lead to jank but we are already working on making this not block the main thread.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.