Disallow accounts from temporary email providers

RESOLVED DUPLICATE of bug 467763

Status

()

Bugzilla
Administration
--
enhancement
RESOLVED DUPLICATE of bug 467763
5 years ago
5 years ago

People

(Reporter: Dolske, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
I've seen a few comments recently (like bug 889681 comment 6) that are using temporary email providers. In that case rmqkr.net goes to 10minutemail.com, but I know there are a number of such services. These are just ripe for abuse, and unlikely to be used as an account for someone serious about helping to report and investigate bugs. Presumably somewhere there's a list of such domains (http://www.block-disposable-email.com/cms/ is one non-free service), we should just blacklist these as spammy domains.

Updated

5 years ago
Severity: normal → enhancement

Comment 1

5 years ago
Just to give an idea of how such accounts are used:

https://bugzilla.mozilla.org/buglist.cgi?emailreporter1=1&emailtype1=substring&email1=%40rmqkr.net

I agree that email accounts such as @rmqkr.net ones are a way to bypass registration, but it's barely more difficult to create a hotmail address.

There is no reason to hardcode this list nor to force all Bugzilla installations to exclude such accounts. What we want is a way for administrators to ban some email providers. The 'createemailregexp' currently doesn't let us do that. We would need another parameter, ideally accepting more than one regexp.
Assignee: user-accounts → administration
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: User Accounts → Administration
Resolution: --- → DUPLICATE
Duplicate of bug: 467763
You need to log in before you can comment on or make changes to this bug.