If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Meet with kang to learn about oprofile

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: huseby, Assigned: huseby)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=profiling s=2013.08.23 p=2])

(Assignee)

Description

4 years ago
I'm going to learn about oprofile so that we can see how it compares to perf_events and possibly crib ideas.  It will also help us defend the use of perf_events in the future.
(Assignee)

Comment 1

4 years ago
I set up a meeting this Wednesday at 11am PST to talk oprofile with Guillaume Destuynder (kang) and getting better low-level perf numbers.
(Assignee)

Comment 2

4 years ago
We met this morning to talk about using oprofile in on-device unit testing to catch performance regressions.  Turns out that oprofile has a legacy mode and a new mode that uses the kernel performace events system.  So there is no decisions between using oprofile and perf_events.

We discussed the idea of writing a scriptable C++ object that can control the kernel performance events system so that we could write on-device unit tests using javascript to monitor actual execution time of the JS API.  It would also allow us to drive the profiling from xpcshell and thus, remote tools running on a host.

There is more to discuss and to try out.  Right now we're not sure if the oprofile tool will compile on android.  There may be issues with the bionic libc.  The information outcome from this meeting will feed into our discussion in Torronto about how we're going to build out our performance unit tests.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.