Caret selection initiated from the end of a text input is buggy

RESOLVED FIXED in Firefox 30

Status

defect
P1
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: Samvedana, Assigned: azasypkin)

Tracking

Trunk
Firefox 30
x86
Windows 8.1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [selection] p=3 s=it-30c-29a-28b.3 r=ff30 [qa-])

Reporter

Description

6 years ago
From bug 854070 comment 23,

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0
Build ID: 20130806104538
Built from http://hg.mozilla.org/mozilla-central/rev/1e381c91885d

Didn't work for me.
Tested on windows 8 using latest nightly  for iteration-11. 

STR
- visit google.com
- enter some text into the search edit
- tap off the edit
- tap at the end of the entered text
(a monocle should appear)
- drag monocle to the left

result: monocle was hidden, no text was selected and sometimes text was selected. See video for more detail: http://youtu.be/kFCfWADvLnA

expected: text must be selected
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0
Blocks: metrov2defect&change
No longer blocks: metrov1backlog

Updated

6 years ago
Whiteboard: [preview-triage] feature=defect c=tbd u=tbd p=0 → [triage] feature=defect c=tbd u=tbd p=0
Whiteboard: [triage] feature=defect c=tbd u=tbd p=0 → feature=defect c=tbd u=tbd p=0
No longer blocks: metrov2defect&change

Updated

6 years ago
Duplicate of this bug: 895279
Summary: Defect - Caret selection initiated from the end of a text input is buggy → Caret selection initiated from the end of a text input is buggy
Whiteboard: feature=defect c=tbd u=tbd p=0 → [defect] p=0
Whiteboard: [defect] p=0 → [defect] p=0 [selection]
Blocks: 957244

Updated

6 years ago
OS: Windows 8 Metro → Windows 8.1
Whiteboard: [defect] p=0 [selection] → [defect] p=3
Priority: -- → P1
Target Milestone: --- → Firefox 30
Whiteboard: [defect] p=3 → p=3 r=ff30
Target Milestone: Firefox 30 → ---
Whiteboard: p=3 r=ff30 → p=3
Looks like bug 858206 is at least one of the reasons for this buggy behavior.
Depends on: 858206
Whiteboard: p=3 → [selection] p=3
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
QA Contact: kamiljoz
Whiteboard: [selection] p=3 → [selection] p=3 s=it-30c-29a-28b.3 r=ff30
Seems that issue is resolved by path for bug 858206.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 30
Whiteboard: [selection] p=3 s=it-30c-29a-28b.3 r=ff30 → [selection] p=3 s=it-30c-29a-28b.3 r=ff30 [qa-]
You need to log in before you can comment on or make changes to this bug.