[Buri][Shira-51010]There is no hint to the user that attachments cannot be stored if no SD card is inserted or the device is connect via USB in USB storage mode

RESOLVED DUPLICATE of bug 894277

Status

Firefox OS
Gaia::SMS
P1
normal
RESOLVED DUPLICATE of bug 894277
4 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [comms-triaged])

(Reporter)

Description

4 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.184
 Firefox os  v1.1
 Mozilla build ID:20130806071254
 DEFECT DESCRIPTION:
  There is no hint to the user that attachments cannot be stored if no SD card is inserted or the device is connect via USB in USB storage mode.
  REPRODUCING PROCEDURES:
  1.There is no pic in MS
  2.New a message,tap attachment icon,select gallery
  3.It doesn't popup notification->KO
  EXPECTED BEHAVIOUR:
  It should popup notification
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  Low
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:

Updated

4 years ago
blocking-b2g: --- → koi?

Updated

4 years ago
blocking-b2g: koi? → leo?
moving to koi? or later in backlog
users would need SD card to use the phone normally (camera/music....etc) 
this would not be a common use case for most users
blocking-b2g: leo? → koi?
Blocks: 905562
ni? to confirm the intended behavior
Flags: needinfo?(aymanmaat)
Whiteboard: [comms-triaged]

Comment 3

4 years ago
Hi Joe, how about device in USB sharing mode? in this senario, there is a prompt when user load from SD but no prompt when user store to SD. Mark leo? again for this confusion.
blocking-b2g: koi? → leo?
Lets improve the user experience on attachments in 1.2
blocking-b2g: leo? → koi?
add to backlog 891754
Blocks: 891754
blocking-b2g: koi? → ---

Comment 6

4 years ago
ok, sorry, i need clarity from the reporter. is this bug about adding an attachment to a message or saving an attachment that has been received with an incoming message?

the description of the bug reads as if it is talking about saving an attachment that has been received with an incoming message, however the procedure in comment 0 reads like it is about adding an attachment to a new message.

ni? to sync-1@bugzilla.tld for clarification
Flags: needinfo?(aymanmaat) → needinfo?(sync-1)
Anyway there are bugs for both of these procedures: bug 911274 for saving and bug 894277 for picking.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 894277

Comment 8

4 years ago
Now I can't reproduce this pr either.
Flags: needinfo?(sync-1)
You need to log in before you can comment on or make changes to this bug.