[B2G][Helix][Camera][zhaodawei]The camera APP crashed when switch beween back/front camera.

RESOLVED DUPLICATE of bug 898326

Status

Firefox OS
Gaia::Camera
P1
critical
RESOLVED DUPLICATE of bug 898326
4 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(blocking-b2g:hd+)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 790044 [details]
the crashed phenomenon

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; aff-kingsoft-ciba; Zune 4.7)

Steps to reproduce:

1. launch camera app 
2. quickly click the front/back switch button manytimes
 



Actual results:

The snapshot and record button was gray and not response.
Only after rebooting the phone, the camera APP can work.


Expected results:

Camera APP will not crash.
(Reporter)

Updated

4 years ago
Severity: normal → critical
Priority: -- → P1
(Reporter)

Comment 1

4 years ago
I think that we can control the progress of camera switching.
For example, when during the progress of switching, we can hiden the switching button untill switching successfully.
(Reporter)

Comment 2

4 years ago
I think that we can control the progress of camera switching.
For example, when during the progress of switching, we can hiden the switching button untill switching successfully.
(Reporter)

Comment 3

4 years ago
I added some codes in funtcion 'toggleCamera: function camera_toggleCamera()'(./gaia/apps/camera/camera/js/camera.js) as follow:

{
  ...
  this.updateFlashUI();
  this.toggleButton.classList.add('hidden');
  this.loadCameraPreview(this._camera, this.enableButtons.bind(this));
  ...
}

After doning this, you cannot quickly click the front/back switch button. 
So there will not be this issue.

What about this modification?
Is this a different issue from bug 890427?
(Reporter)

Comment 5

4 years ago
(In reply to Mike Habicher [:mikeh] from comment #4)
> Is this a different issue from bug 890427?

I checked that the following patch had merged in our baseline.
 https://hg.mozilla.org/releases/mozilla-b2g18_v1_1_0_hd/rev/1433d653b701 

And then I merged the gaia patch in our baseline, you also can touch fast and repetitively on toggle button.
  https://github.com/mozilla-b2g/gaia/commit/376d45c7afdbf97f75d55803e15fbb87931f3a50

It seems that the function 'this.disableButtons();' did not work as expected.

So it can't fix our issue.
It is not clear which part's of the code is responsible for this bug. For bug 890427, gecko had a responsibility to fix it. But for example like Bug 895857, vendor proprietary part had a responsibility. Without the investigation of why the problem happens, it is not clear which part should fix.

I do not have helix device. IIRC, only taiwan office's engineers has helix devices in mozilla.
(Reporter)

Updated

4 years ago
blocking-b2g: --- → hd?
Sotaro, 

do you know who can handle it in taiwan?? I can help to contact him.

Comment 8

4 years ago
This problem was solved by Vincent and Gary.


-------- Change the status to "RESOLVED-DUPLICATE" --------
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 898326
duped to an hd+ resolved bug
blocking-b2g: hd? → hd+
You need to log in before you can comment on or make changes to this bug.