[wasabi] After MO a call and launch data call needed app during the call, data call is not working even though 3g icon is on status bar.

RESOLVED INVALID

Status

Firefox OS
General
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Enpei, Assigned: jessica)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

4 years ago
After MO a call and launch data call needed app during the call, then end the call. Then try to load web pages and marketplace, data call is not working even though 3g icon is on status bar.

* Build Number                
    Gaia mozillaorg/master - 36c1af870731e906b33028418b9abaab58919b7d
    Gecko mozillaorg/master - 4d14292521d447cc488fd93b19b261934ba2a8b2
    v1.2

* Reproduce Steps
1. Make sure data call is working.
2. MO a call, and try to open web page during the call. 
3. End the call.
4. 3g icon is still there. Try to open web page and marketplace. (Time stamp of attached log: 19:03, 8/14

* Expected Result
Data call can still working.

* Actual Result
Pages cannot be loaded.

* Occurrence rate
Met 2 times out of 4 trials.
blocking-b2g: --- → koi?
Summary: [wasabi] → [wasabi] After MO a call and launch data call needed app during the call, data call is not working even though 3g icon is on status bar.
(Reporter)

Comment 2

4 years ago
Created attachment 790141 [details]
logcat with ril log enabled.

Comment 3

4 years ago
according to the RIL triage meeting consensus on 8/22, koi+ this issue.
blocking-b2g: koi? → koi+

Comment 4

4 years ago
Jessica, need your help.
Assignee: nobody → jjong
(Reporter)

Comment 5

4 years ago
Hi Jessica,

As we talked on the phone, I tried about 3 to 4 times in the beginning with the steps below but no luck to find the bug:
1. MO call
2. Open a website during the call
3. End the call, go back to browser and load another website

Then I change steps to 
1. MO call.
2. Open a website during the call
3. End the call, open Marketplace at 11:08, it cannot load marketplace but when I tried to open a website, data call is back again.

So I repeat above steps again at 11:13, data call is not working anymore. Here is the route info captured at that time.
Iface   Destination     Gateway         Flags   RefCnt  Use     Metric  Mask
        MTU     Window  IRTT

rmnet0  00000000        61B8A70A        0003    0       0       0       00000000
        0       0       0

rmnet0  60B8A70A        00000000        0001    0       0       0       F8FFFFFF
        0       0       0
(Reporter)

Comment 6

4 years ago
Created attachment 795815 [details]
with tcpdump reproduced with build 20130826061633
(Assignee)

Comment 7

4 years ago
Hi Enpei,

As discussed offline, logcat main log starts from 11:24.
From tcpdump, there were lots of outgoing packets and no incoming packets starting from 11:13.

Let us summarize your test results again...
Using N97, with Android, data can not be used after voice call ended, this happens every time; with FxOS, sometimes data can not be used after voice call ended, not easy not reproduce.
Am I correct?

Thanks.
(Reporter)

Comment 8

4 years ago
Hi Jessica,

Attached log again and hope that RIL log is the right one now. Issue started at 15:28, but data call recovered at 15:36. I'll try more time if any chance to meet no data call working anymore case.

As for your question, yes, each time hang up call on android version, I can see EV icon becomes green with only UL animation, it cannot fall back to 1x data call.
(Reporter)

Comment 9

4 years ago
Created attachment 795893 [details]
timestamp: 15:28~15:36.
(Assignee)

Comment 10

4 years ago
Hi Enpei,

Thanks for testing again.

From gecko layer, PS was registered and data was connected all the time, only network type has changed from evdo to 1xrtt.

08-27 15:28:54.347 I/Gecko   (  201): -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":"46605","shortName":"","mcc":"466","mnc":"05"},"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1},"type":"evdob","signalStrength":-56,"relSignalStrength":100,"state":"registered","apn":"APTNET"}}
...
08-27 15:35:59.762 I/Gecko   (  538): -*- RILContentHelper: Received message 'RIL:DataInfoChanged': {"clientId":0,"data":{"connected":true,"emergencyCallsOnly":false,"roaming":false,"network":{"longName":"46605","shortName":"","mcc":"466","mnc":"05"},"cell":{"gsmLocationAreaCode":-1,"gsmCellId":-1},"type":"1xrtt","signalStrength":null,"relSignalStrength":null,"state":"registered","apn":"APTNET"}}


What is strange from tcpdump is that, there were lots of outgoing packets and no incoming packets from 15:28~15:36 using source IP 10.138.89.162, then at 15:36 source IP has changed to 10.157.57.68, and packets were coming in again.

From logcat, ril didn't do anything to change IP, but we do see some UNSOLICITED_DATA_CALL_LIST_CHANGED events. So, I think this seems to be more like a network issue.
(Assignee)

Comment 11

4 years ago
Created attachment 795923 [details]
tcpdump screenshot

ip changed from at 15:36 and data started working again.
This is also reproducible under CT network with EVDO only, CDMA only and CDMA/EVDO mode.

It seems it always switch to 1x mode during voice call, however data connection never works when a voice call is established.
(Reporter)

Comment 13

4 years ago
Hi Peipei,

Can you try the step and observe the data call function after end the call? The issue is found after the call and data call can never work even icon is there. Like fail to loading webpage or open marketplace.
After ending call, the data call works very soon. Web pages can be open.

(In reply to echu from comment #13)
> Hi Peipei,
> 
> Can you try the step and observe the data call function after end the call?
> The issue is found after the call and data call can never work even icon is
> there. Like fail to loading webpage or open marketplace.
I tried 6 times (2 for each mode: cmda only, EVDO only, cmda/evdo). Data call works after ending call although sometimes cdma only network is slow.
(Reporter)

Comment 16

4 years ago
Reference phone is not configured for APTG network, since the issue is not found under China Telecom network, I will close it until we have target partner device.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Updated

4 years ago
blocking-b2g: koi+ → ---
You need to log in before you can comment on or make changes to this bug.