Closed Bug 905136 Opened 7 years ago Closed 7 years ago

Blackbox icons missing from debugger (Linux)

Categories

(DevTools :: Debugger, defect)

x86
Linux
defect
Not set
normal

Tracking

(firefox25+ verified, firefox26 verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox25 + verified
firefox26 --- verified

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(3 files, 1 obsolete file)

It just shows checkboxes. The checkbox binding is different under Linux so the CSS doesn't apply properly. I'll confirm this is the cause once my tree is working again.
Blocks: 877686
Attached patch 905136-1.diff (obsolete) — Splinter Review
This fixes the problem, but there's still a stray focus rectangle of about 3px x 3px.
image ?
That must be the work of border. You might need border: none !important;
This is just bug 669507 striking again. Someone should fix that.
I'm not sure what I'm looking at, so I'll ask dcamp :)

Is this critical enough to track for release?
Flags: needinfo?(dcamp)
Yeah, please track this for release.
Flags: needinfo?(dcamp)
Can we retest this after bug 905046 lands in m-c?
Status: NEW → RESOLVED
Closed: 7 years ago
Depends on: 905046
Resolution: --- → DUPLICATE
Duplicate of bug: 905046
Not a dupe, the CSS selectors need to be changed in the Linux theme.
(Tested on Nightly just to make sure.)
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Attachment #790184 - Flags: review?(nfitzgerald)
Depends on: 669507
Comment on attachment 790184 [details] [diff] [review]
905136-1.diff

Hmmmm, patch doesn't apply for me on fx-team.

I don't have a linux box handy, maybe Mihai can be your reviewer?
Attachment #790184 - Flags: review?(nfitzgerald) → review?(mihai.sucan)
Attached patch 905136-2.diffSplinter Review
(In reply to Nick Fitzgerald [:fitzgen] from comment #8)
> Comment on attachment 790184 [details] [diff] [review]
> 905136-1.diff
> 
> Hmmmm, patch doesn't apply for me on fx-team.

Oh, of course it doesn't. My mistake.
Attachment #790184 - Attachment is obsolete: true
Attachment #790184 - Flags: review?(mihai.sucan)
Attachment #792532 - Flags: review?(mihai.sucan)
Comment on attachment 792532 [details] [diff] [review]
905136-2.diff

Without this patch: I see checkboxes for the blackboxing feature.

With this patch: I see the eye icon for blackboxing.

I tested on Ubuntu 12.04.
Attachment #792532 - Flags: review?(mihai.sucan) → review+
Geoff: thanks for the bug report and for the fix.
Thanks for reviewing Mihai :)
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/460f2574cbd2
Assignee: nobody → geoff
Status: REOPENED → ASSIGNED
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/460f2574cbd2
Status: ASSIGNED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Mihai, can you help with an uplift request to Beta 25 here?
Flags: needinfo?(mihai.sucan)
Sure! This is the rebased patch for mozilla-beta (Firefox 25).


[Approval Request Comment]
Bug caused by (feature/regressing bug #): feature exposed by new UI in bug 877686.
User impact if declined: the icon for blackboxing sources in the JS debugger will not show for Linux users.
Testing completed (on m-c, etc.): patch landed in fx-team and m-c for some time already.
Risk to taking this patch (and alternatives if risky): minimal to none.
String or IDL/UUID changes made by this patch: none.

Thank you!
Attachment #808800 - Flags: approval-mozilla-beta?
Flags: needinfo?(mihai.sucan)
Attachment #808800 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: verifyme
Blackbox eye is functional now, but there is a small red circle near the eye, which remain displayed after turning off blackboxing. What is it for ? It's displayed only on Linux. Tested on FF 25b3, Ubuntu 13.04
Flags: needinfo?(geoff)
(In reply to Paul Silaghi [QA] from comment #18)
> Blackbox eye is functional now, but there is a small red circle near the
> eye, which remain displayed after turning off blackboxing. What is it for ?
> It's displayed only on Linux. Tested on FF 25b3, Ubuntu 13.04

It's the focus rectangle for the checkbox, bug 669507.
Flags: needinfo?(geoff)
Verified fixed on FF 25b3 Ubuntu 13.04, based on comment 19.
The blackbox eye is smaller in FF 26, 27 compared to FF 25. Is it expected?
Verified fixed on FF 26.0a2 (2013-10-03) Ubuntu 13.04
Status: RESOLVED → VERIFIED
Keywords: verifyme
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.