Test failure "Extension 'test-long-name@quality.mozilla.org' is disabled - got 'false'" in /testAddons_uninstallExtension/test3.js

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: cosmin-malutan, Unassigned)

Tracking

({reproducible})

unspecified
reproducible

Firefox Tracking Flags

(firefox25 unaffected, firefox26 fixed)

Details

(Whiteboard: [mozmill-test-failure][fixed by bug 911621], URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Happened today on Windows 7 (x86) with Nightly it
http://mozmill-daily.blargon7.com/#/functional/report/b7ef1fb3d9703aeaf2c46e07d2bbd41a

This one I can't reproduce it locally.
(Reporter)

Updated

5 years ago
status-firefox26: --- → affected
(Reporter)

Updated

5 years ago
OS: Linux → Windows 7
Hardware: x86_64 → x86
Whiteboard: [mozmill-test-failure]
(Reporter)

Comment 1

5 years ago
Still cant' reproduce this failure.
(Reporter)

Comment 2

5 years ago
It's reproducible with the latest Nightly , I will return with a skip patch in a moment.
http://mozmill-daily.blargon7.com/#/functional/report/dc3d4d2f66af31b9e75e291fa0213fcc
Keywords: reproducible

Updated

5 years ago
OS: Windows 7 → All
Priority: -- → P1
Hardware: x86 → All
(Reporter)

Comment 3

5 years ago
Created attachment 803696 [details] [diff] [review]
skip.patch

Here is the skip patch.
Attachment #803696 - Flags: review?(andrei.eftimie)
Attachment #803696 - Flags: review?(andreea.matei)

Comment 4

5 years ago
Comment on attachment 803696 [details] [diff] [review]
skip.patch

Review of attachment 803696 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/restartTests/testAddons_uninstallExtension/manifest.ini
@@ +5,2 @@
>  [test3.js]
> +disabled = Bug 905193 - Test failure 'Extension 'test-long-name@quality.mozilla.org' is disabled - got 'false'

There is no need to also disable them here since this manifest file is skipped altogether
Attachment #803696 - Flags: review?(andrei.eftimie)
Attachment #803696 - Flags: review?(andreea.matei)
Attachment #803696 - Flags: review-
(Reporter)

Comment 5

5 years ago
Created attachment 803703 [details] [diff] [review]
skip.patch

I skipped the tests in /testAddons_uninstallExtension/manifest.ini too where it's no necessary, so here is an updated patch.
Attachment #803696 - Attachment is obsolete: true
Attachment #803703 - Flags: review?(andrei.eftimie)
Attachment #803703 - Flags: review?(andreea.matei)

Comment 6

5 years ago
Comment on attachment 803703 [details] [diff] [review]
skip.patch

Review of attachment 803703 [details] [diff] [review]:
-----------------------------------------------------------------

Disabled:
http://hg.mozilla.org/qa/mozmill-tests/rev/b4ffbde16c41 (default)
Attachment #803703 - Flags: review?(andrei.eftimie)
Attachment #803703 - Flags: review?(andreea.matei)
Attachment #803703 - Flags: review+
Attachment #803703 - Flags: checkin+

Updated

5 years ago
status-firefox26: affected → disabled
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][mozmill-test-skipped]
Please don't forget to add dependencies. I think it's caused by the same problem as for all the other tests? So it should be dependent on bug 911820.
status-firefox25: --- → unaffected
Depends on: 911820
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure][mozmill-test-skipped][blocked by bug 911820]
No longer depends on: 911820
Depends on: 911621
Fixed by bug 911621 and reenabled in bug 915193.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox26: disabled → fixed
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mozmill-test-skipped][blocked by bug 911820] → [mozmill-test-failure][blocked by bug 911820]
Whiteboard: [mozmill-test-failure][blocked by bug 911820] → [mozmill-test-failure][fixed by bug 911621]
You need to log in before you can comment on or make changes to this bug.