False (I think) Error Console Messages

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: john, Unassigned)

Tracking

22 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0 (Beta/Release)
Build ID: 20130618035212

Steps to reproduce:

On my website: http://www.galapagos.to/MAPS/INDEX.PHP, practically every link opens a small window to display an image of a map. One example is the following:
http://www.galapagos.to/MAPS/L-945.HTM (it's the first link on the above page).



Actual results:

When the L-945.HTM file opens in a small window, the Error Console reports the following errors:
XUL box for_moz-generated_content_ . . . children to be wrapped in a block.
Unknown property 'box-sizing'. Declaration dropped. (This line displayed three times, first with "box-sizing: border-box; (and so on)" and then twice with "padding-0; (and so on)." However, if I instead use the above URL to directly open the L-945.HTM file, no error messages appear, and the page validates in strict mode at validator.w3.org


Expected results:

No errors should be reported, as there are none. This set of Error Console messages started appearing several months ago -- I guess after one of the Firefox updates. 
So, is there any way to kill these apparently incorrect messages?

Thanks,
John Woram

Comment 1

5 years ago
I see no error message about your website with FF23 on Win 7.

1) Update to Firefox 23.

2) Try in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

3) Try with a clean profile: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Does it fix it?
Component: General → Untriaged
Flags: needinfo?(john)
Product: Core → Firefox
(Reporter)

Comment 2

5 years ago
I did an update to 23, then reset FF. That didn't fix it, so I did a clean profile, and that didn't fix it either. However, now I only see 3 warnings:
Unknown property 'box-sizing'. Declaration dropped. (repeats 3 times, with the following (which is line 2 in each warning).
chrome://web-developer/content/toolbar/html/element-ancestors.html

The final line of each warning is:
box-sizing:border-box; (and so on) First warning.
padding:0; . . . box-sizing:content-box; (and so on) The final lines of warnings 2 and 3 are identical.
Flags: needinfo?(john)

Comment 3

5 years ago
(In reply to John Woram from comment #2)
> chrome://web-developer/content/toolbar/html/element-ancestors.html

This indicates the warnings are coming from the "Web Developer" add-on [1].  Could you please start Firefox in safe mode with add-ons disabled as Loic suggests and report back if the warnings still happen?

The MDN box-sizing page [2] says (at the very bottom) that "There isn't yet a non-prefixed implementation in Gecko," so the add-on should be using -moz-box-sizing instead of box-sizing.

[1] https://addons.mozilla.org/en-US/firefox/addon/web-developer/
[2] https://developer.mozilla.org/en-US/docs/Web/CSS/box-sizing
Flags: needinfo?(john)

Updated

5 years ago
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 4

5 years ago
(In reply to Drew Willcoxon -- Comment 3
Really weird: In Safe Mode, if I open http://www.galapagos.to/maps/L-945.htm, the Error Console is empty (no errors/warnings/messages)
If I re-enable Avast Online Security 8.0.1489, I get:
Errors:
TypeError:this.button is null
chrome://wrc/content/overlay.js
Warnings: (50 or more -- too numerous to include here)
Messages: (multiple Avast Log messages)
If I open the above file as a javascript pop-up, I get:
Errors: 7 of them, including:
syntax error (2)
"junk after document element" (2)
undefined entity: <div>&nbsp;</div>
That last one makes no sense at all -- The cited file is in the Program Files/Avast folder, and there's nothing wrong with that <div> line.
The Warnings tab shows 16 "Reference Error" warnings.
The Messages tab shows multiple Avast Log messages, as above, but many more of them.

Now, if I disable Avast, re-enable Web developer, and once again run that L-945.HTM file in its own window, the Error Console remains empty. But if I open it as a Javascript pop-up window, I get:
Errors: (none)
Warnings: Many SyntaxError and TypeError lines, to numerous to include here.
Messages: (none) 

Those multiple SyntaxError and TypeError lines are something new, and I have no idea why they are just now starting to appear. In any case, it seems (to me, that is) that after writing a new pop-up window file, I should open it as a non-pop-up and verify there are no errors. Then, just ignore all those Error Console messages that show up when the file opens as a javascript pop-up window.

If I remember rightly, much of the above started happening with a Firefox upgrade earlier this year. And then it got much worse after upgrading to version 23.0.1. Maybe it'll get better with a subsequent upgrade.

Comment 5

5 years ago
We are not able to repro these error messages with a clean profile. Maybe contact the add-on dev and tell him about this bug.

About Avast like others, these security suites imply various bad behaviors for the user when they are trying to sniff internet traffic. Not really new.

Comment 6

5 years ago
Resolving WFM since this sounds like a problem with the add-on.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(john)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.