[FTE] First time after flashing/reseting the device, clicking in a field will bring up the keyboard tutorial page.

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nhirata, Assigned: mihai)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 fixed)

Details

"gecko" revision="3c61cc01a3b1"
"gecko" revision="b33cd2bd329d8e051424e7a059e7443492f5ba01"
"gaia" revision="9e0f6e30e5e28f88b4bbb4acb5e1fc99cdf7b7e7"
Build ID: 2013-08-14-04-02-03
MC/master build/eng
Unagi

1. flash device or reset the device (settings -> device info -> more info -> reset phone)
2. wait for the device to come back up
3. select English 
4. select next for Cellular Data
5. select network
6. tap in password field

Expected: keyboard
Actual : tutorial page

Note:
1. video : http://www.youtube.com/audio?feature=vm&v=QdppXmcO7-k
This happens on buri as well.

Note: it's the first text field it hits.  ie if there's a pin lock on the SIM card, it will show there instead.
(Assignee)

Updated

5 years ago
Assignee: nobody → mihai
The tutorial screen is for dismiss keyboard (i.e. swipe keyboard down) and was introduced by the patch for bug 805586.

I am not sure if this should not be shown during FTU, when the user invokes the keyboard for the first time, so adding needinfo for Rudy.

A better link for the video from the description is: http://youtu.be/QdppXmcO7-k?t=1m25s
Flags: needinfo?(rlu)
Yes, this tutorial screen is in keyboard app, not in FTU app itself.
For current design, we cannot know whether the clicked input field is in FTU or not, so it is not possible to avoid showing this screen in during FTU.

We need UX input on when/where to show this tutorial screen for keyboard if they agree this is a significant issue.

+cc Neo and Carrie, UX designers for keyboard/IME.
Thanks.
Flags: needinfo?(rlu)
Flags: needinfo?(nhsieh)
Flags: needinfo?(cawang)

Comment 4

5 years ago
Yes, sometimes users may skip FTU or doesn't input anything. So we will propose that is only waking up at first time launch keyboard app.
Flags: needinfo?(nhsieh)
I guess Comment 4 means that UX is ok with the current behavior.
Naoki, 
Do you agree we can close this issue?
Flags: needinfo?(cawang)
Adding needinfo for Naoki to reply to comment 6.
Flags: needinfo?(nhirata.bugzilla)
I think it's an odd behavior to have the first time you use any field to bring up that tutorial.
Does it really warrant a tutorial for the keyboard?

I have heard other QA comment the same as well.
Flags: needinfo?(nhirata.bugzilla)
UX,

Please comment if the empty box is an issue or not. It is not breaking anything.
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 10

5 years ago
Flagging Jaime as she has a good sense of what's up with E.me design.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(jachen)

Comment 11

5 years ago
Hey there-
This isn't about e.me but its about the first time use of keyboard. So its about whether this step makes sense at all in any first run context (whether first use or reset device).

I need to dig into the history of this and UX will respond shortly.

Thanks!
Jaime
Flags: needinfo?(jachen)
Summary: [FTE] First time after flashing/reseting the device, clicking in a field will bring up the Everything.me tutorial page → [FTE] First time after flashing/reseting the device, clicking in a field will bring up the keyboard tutorial page.

Updated

5 years ago
blocking-b2g: koi? → koi+
Summary: [FTE] First time after flashing/reseting the device, clicking in a field will bring up the keyboard tutorial page. → [FTE] First time after flashing/reseting the device, clicking in a field will bring up the Everything.me tutorial page
Discussed this in triage and its not an annoying experience for a first time user hence blocking
Summary: [FTE] First time after flashing/reseting the device, clicking in a field will bring up the Everything.me tutorial page → [FTE] First time after flashing/reseting the device, clicking in a field will bring up the keyboard tutorial page.
Mihai, given this is not being worked on can we backout the change related to tutorial page to avoid this experience ?
(In reply to bhavana bajaj [:bajaj] from comment #13)
> Mihai, given this is not being worked on can we backout the change related
> to tutorial page to avoid this experience ?

I think we are still waiting for UX input on this (as per comment 11).

Comment 15

5 years ago
I apologize that UX was not re-flagged. I am flagging Carrie and Mike on FTE for Keyboard. This is koi+ so please address this as soon as you can.
Flags: needinfo?(mtsai)
Flags: needinfo?(cawang)

Comment 16

5 years ago
As far as I am concerned. Users won't pay attention to what he/she is on at the moment. So In my opinion. When users enter a text filed for the first time ( or after reseting system , a simple and clear tutorial should occur when they first use keyboard. No too much wording or complicated image, user gets the idea of how it works in the end.
Flags: needinfo?(mtsai)
Hi everyone, the occurrence timing of the keyboard tutorial is the first time keyboard use AFTER FTE. We shouldn't interrupt users with the tutorial during FTE settings. Users can't really learn how to use the kb while focusing on setting up the device. Thanks!
Flags: needinfo?(cawang)
Hi everyone, we've discussed this issue for a while. Since removing the page won't cause too much effort and regression. We'd suggest to hide the keyboard tutorial as a temporary solution. 
About the next step, we'll add some description on the page to indicate users how to close the keyboard and also remove the page from FTE to the first time use after FTE. 
Need info Rudy to confirm the engineering effort. Thanks!
Flags: needinfo?(rlu)
We already have a (one-line) patch in Bug 925318, so the effort and risk is quite low here.
Thanks for the suggestion.
Flags: needinfo?(rlu)

Updated

5 years ago
Duplicate of this bug: 925318
Patch landed to remove the keyboard tutorial screen,
https://github.com/mozilla-b2g/gaia/commit/1e212079cca612f9a91bd79ad6042f90748ce9d7
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(In reply to Rudy Lu [:rudyl] from comment #21)
> Patch landed to remove the keyboard tutorial screen,
> https://github.com/mozilla-b2g/gaia/commit/
> 1e212079cca612f9a91bd79ad6042f90748ce9d7

This also landed in v1.2
status-b2g-v1.2: --- → fixed
Not sure why, but this patch was never uplifted to v1.2 branch but this bug has been set as status-b2g-v1.2:fixed.

--
Gaia v1.2,
https://github.com/mozilla-b2g/gaia/commit/92cd11ea023dd6598d82d859ae3c945ff6589ce6
You need to log in before you can comment on or make changes to this bug.