Closed Bug 905371 Opened 6 years ago Closed 6 years ago

Remove session restore prefs from Fx25

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 25
Tracking Status
firefox25 --- verified
firefox26 --- unaffected

People

(Reporter: bnicholson, Assigned: bnicholson)

References

Details

Attachments

(1 file)

Session restore prefs are being changed from 3-state to 2-state (bug 904741). Rather than release this feature and confuse users with the change, we can just wait until Fx26 to expose this pref.
My first instinct was to just remove the prefs from the XML and be done with it, but we need to actually remove the logic itself so people who have already changed this in Aurora aren't stuck with a residual pref behavior for 6 weeks.
Attachment #790444 - Flags: review?(mark.finkle)
Comment on attachment 790444 [details] [diff] [review]
Remove session restore pref

Looks good. Does not remove strings (which is good).
Attachment #790444 - Flags: review?(mark.finkle) → review+
Comment on attachment 790444 [details] [diff] [review]
Remove session restore pref

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 801412 and bug 896515
User impact if declined: session restore pref will change in next release, causing confusion
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): very low risk
String or IDL/UUID changes made by this patch: none
Attachment #790444 - Flags: approval-mozilla-aurora?
Blocks: 801412, 896515
Comment on attachment 790444 [details] [diff] [review]
Remove session restore pref

no string removal, no user impact until FF26 (bug 904741) - approved for aurora.
Attachment #790444 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 25
And backed out for robocop failures.
https://hg.mozilla.org/releases/mozilla-aurora/rev/674c5378780c

https://tbpl.mozilla.org/php/getParsedLog.php?id=27032460&tree=Mozilla-Aurora

Also, is this a bad time to remind you that you are responsible for watching your pushes to Aurora per the tree rules? This was burning and you were nowhere to be found. As much as I love doing backouts at 9pm, I would prefer if you were doing them yourself.
Sorry about that -- I forgot that this didn't land on m-c first and never had a test run. I'll be more careful in the future.

Try run with pref changes: https://tbpl.mozilla.org/?tree=Try&rev=1ed634d30589
Verified fixed:
Build: Firefox for Android 25.0a2 (2013-08-27)
Device: Asus Transformer TF 101
OS: Android 4.0.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.