Closed Bug 905411 Opened 7 years ago Closed 4 years ago

www.spin.com - clicking "DOWNLOAD MP3" link hangs Firefox

Categories

(Web Compatibility :: Desktop, defect, critical)

defect
Not set
critical

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mats, Unassigned)

References

()

Details

(Keywords: hang)

See bug 786297 for steps to reproduce the problem.

The site has an error in the script that generates the page for
playing the song (when clicking said link).  The whole MP3
contents is injected into the page which makes the browser try
to render it as HTML which leads to extremely bad performance
(hang) in Firefox.

The problem also occurs in Chrome, but it seems to render the
binary data without performance problems.
Issue still exists. It looks like they stopped providing MP3 files though, most "check this out" articles are links to streams like Soundcloud.
Assignee: english-us → nobody
Component: English US → Desktop
link is 404
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.