Disabling keyword.enabled and entering a wrong URI assert

RESOLVED FIXED in mozilla26

Status

()

Core
Document Navigation
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: evilpie, Assigned: evilpie)

Tracking

unspecified
mozilla26
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
So I noticed this, because at the moment child processes can't do proper URIFixup. But the problem can be reproduce on a normal build by setting keyword.enabled to false and entering "bla bla" into the urlbar.

0x00007ffff05e5468 in nsDocShell::CreateContentViewer (this=0x7fffc9974800, aContentType=0x7fffc74221c8 "application/xhtml+xml", request=0x7fffca9bd8f0, aContentHandler=0x7fffc7471588)
    at /home/tom/mozilla-inbound/docshell/base/nsDocShell.cpp:8008
8008	        MOZ_ASSERT(failedURI, "We don't have a URI for history APIs.");

This seems to happen, because Stop resets mFailedURI before we end up in CreateContentViewer. I think this was caused by Bug 382702.
(Assignee)

Comment 1

4 years ago
Created attachment 790806 [details] [diff] [review]
possible fix?

This doesn't seem much worse than what we had before and ensures that this assert doesn't happen. Only downside is a blank page in your history, but that would probably also happen when the old code worked.
(Assignee)

Updated

4 years ago
Attachment #790806 - Flags: review?(bugs)

Comment 2

4 years ago
Comment on attachment 790806 [details] [diff] [review]
possible fix?

Yeah, I think we can do this. 
nsDocShell::LoadErrorPage is not exactly beautiful code. 
Oddity from 2002.
Attachment #790806 - Flags: review?(bugs) → review+
(Assignee)

Comment 3

4 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/9fd000703ace
https://hg.mozilla.org/mozilla-central/rev/9fd000703ace
Assignee: nobody → evilpies
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
You need to log in before you can comment on or make changes to this bug.