Last Comment Bug 905561 - PyPi package index is busted for a couple of packages since latest version bump
: PyPi package index is busted for a couple of packages since latest version bump
Status: RESOLVED FIXED
: regression
Product: Testing
Classification: Components
Component: Mozbase (show other bugs)
: unspecified
: All All
: -- blocker (vote)
: ---
Assigned To: Henrik Skupin (:whimboo) [away 09/30 - 10/06]
: Henrik Skupin (:whimboo) [away 09/30 - 10/06]
:
Mentors:
Depends on: 905638
Blocks: 906572 895940
  Show dependency treegraph
 
Reported: 2013-08-15 01:28 PDT by Henrik Skupin (:whimboo) [away 09/30 - 10/06]
Modified: 2013-08-22 03:46 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-15 01:28:44 PDT
It looks like that since Andrew bumped the version of a lot of our mozbase packages for the m-c merge, no downloadable files are present anymore! In detail all versions of those packages have been removed! Not sure what went wrong at this time. But this totally busted us now, when you try to install mozmill 2.0 rc4. 

The responsible changeset is:
https://github.com/mozilla/mozbase/commit/c7417faafd0238e2a8da1a1cb08195caff44fde7

I will try to restore most of those packages now. Andrew please try to remember if you had any issues with uploading packages at this time.
Comment 1 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-15 01:31:32 PDT
Ok, looks like older versions of those packages can be installed. So it might be that only the new versions have been registered but the file has never been uploaded.

$ pip install mozinfo
Downloading/unpacking mozinfo
  Downloading mozinfo-0.5.tar.gz
  Running setup.py egg_info for package mozinfo
    
$ pip install mozinfo==0.6
Downloading/unpacking mozinfo==0.6
  Could not find a version that satisfies the requirement mozinfo==0.6 (from versions: 0.4, 0.3.2, 0.3.3, 0.5)
No distributions matching the version for mozinfo==0.6

I will push all affected packages to PyPI now.
Comment 2 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-15 01:48:02 PDT
Submitting dist/ManifestDestiny-0.5.7.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/mozb2g-0.3.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/mozcrash-0.8.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/mozhttpd-0.6.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/mozinfo-0.6.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/mozInstall-1.7.tar.gz to http://pypi.python.org/pypi
Server response (200): OK


Sadly I was not able to update the following packages due to missing permissions. We should really enforce that everyone of us gets them when a new package gets created!

* mozfile
* moznetwork
* moztest

Can you please give me those permissions or upload the packages? Thanks.
Comment 3 William Lachance (:wlach) 2013-08-15 06:53:03 PDT
I added you to moznetwork and moztest, but I don't have permissions to mozfile either. I filed bug 905638 to get this problem corrected.
Comment 4 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-15 06:53:36 PDT
William gave me permissions for moznetwork and moztest. So both are fixed too:

Submitting dist/moznetwork-0.22.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Submitting dist/moztest-0.2.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

Both versions I have hidden given that we already have newer versions up on pypi.

So only moztest remains to be fixed now.
Comment 5 Andrew Halberstadt [:ahal] 2013-08-15 07:03:43 PDT
I remember at the time the pypi server was having a lot of problems, 500 errors etc. I guess it got into some weird state where the package was registered but not uploaded? Anyway, thanks for catching this. I added you to mozfile.
Comment 6 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-15 07:04:39 PDT
Finally uploaded mozfile:

Submitting dist/mozfile-0.10.tar.gz to http://pypi.python.org/pypi
Server response (200): OK

We are done! Thanks.
Comment 7 Jeff Hammel 2013-08-16 11:02:08 PDT
We should probably check post-upload in versionbump.py if the package is downloadable.
Comment 8 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-16 14:14:10 PDT
(In reply to Jeff Hammel [:jhammel] from comment #7)
> We should probably check post-upload in versionbump.py if the package is
> downloadable.

That is a fantastic idea, Jeff! Otherwise I think it should be enough to check for the 200 HTTP response (see above). Let get this bug filed.
Comment 9 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-22 02:40:09 PDT
Not really sure if that was really our fault. Today I have seen the same problem with packages which are not under our control. Might be that a change on PyPI busted a couple of packages.

For example see: https://pypi.python.org/pypi/python-jenkins/
Comment 10 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2013-08-22 03:46:18 PDT
I filed a ticket on bitbucket for pypi:
https://bitbucket.org/pypa/pypi/issue/55/could-not-find-any-downloads-that-satisfy

Note You need to log in before you can comment on or make changes to this bug.