[B2G][Helix][Audio][tianhuajian]The music player can not play aac with adts container format music

RESOLVED DUPLICATE of bug 905022

Status

Firefox OS
Gaia::Music
RESOLVED DUPLICATE of bug 905022
5 years ago
4 years ago

People

(Reporter: tianhuajian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

Preconditions: have a music file in the AAC format transferred to device
1. Open Music app
2. Select Playlist button
3. Select Recently Added option (check all other playlists)
4. Select your AAC file




Actual results:

- No file is presented in any of the playlists.



Expected results:

User is able to locate recently added AAC file and play it
(File is stored on the device, user is able to locate it and play on PC when connected via USB)
If I use aac with mp4 containter, the device can play it .
So I want to know whether FFOS can support aac with adts containter,  what should I to do if I want to support this?

Updated

5 years ago
Component: General → Gaia::Music

Comment 1

5 years ago
Looks like bug 882982.

Comment 2

5 years ago
We didn't support AAC in adts container and support in mp4 container only.

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 905022

Comment 4

4 years ago
Can you give me the solution plan of this problem?
Thanks
You need to log in before you can comment on or make changes to this bug.