Font size combobox doesn't show current value in some larger fonts

VERIFIED WORKSFORME

Status

SeaMonkey
Preferences
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Koike Kazuhiko, Assigned: David Hyatt)

Tracking

({intl})

Trunk
mozilla1.0
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Font size combobox in preferences dialog doesn't show current value.
It shows "...".

This is a regression from several days before. 2001071008/Linux works fine.
what build and what theme are you using? is your build a branch or trunk build?

this wfm using 2001.07.11.0x-comm trunk *and* branch bits on linux, with either
theme.

anyone else see this?
(Reporter)

Comment 2

17 years ago
Trunk build with modern theme.

what build date/time?
(Reporter)

Comment 4

17 years ago
Latest builds after 2001071008. But another user reported this bug for
2001070721/Linux-gcc295. 






i still don't understand --what is the buildid in the titlebar of the app your
using? or, are you using a cvs build from post 7/10 8am?
(Reporter)

Comment 6

17 years ago
Reproduced with 2001071021 and cvs builds from 7/11.

It may be necessary to remove ~/.mozilla to reproduce this bug. 
hrm, i have a linux mozilla trunk debug built at 19:30-ish today, and i still
don't see "..." for the currently displayed value for the font size droplists.
[just numbers, as expected.] i even tried after removing ~/.mozilla [well,
renaming] --with both migrated and non-migrated profiles.

anyone else able to see this with even more recent bits? if so, please do reopen
--and add any additional steps i might be missing.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

17 years ago
I'd found this is a Japanese locale problem.

Font size combobox is displayed correctly if I unset environment variable LANG,
which is usually set to ja_JP.eucJP.
Status: RESOLVED → REOPENED
Keywords: intl
Resolution: WORKSFORME → ---

Comment 9

17 years ago
nav triage team:

Looks like a toolkit issue, reassigning to trudelle
Assignee: sgehani → trudelle
Status: REOPENED → NEW
talked with hyatt. what's probably happening is that we're not guaranteeing 
enough space in the button to fit the entire text of the selected item. menulist 
should be extended to ensure that happens.

--> hyatt for 1.0
Assignee: trudelle → hyatt
Summary: Font size combobox doesn't show current value → Font size combobox doesn't show current value in some larger fonts
Target Milestone: --- → mozilla1.0
QA Contact: sairuh → teruko
(Reporter)

Comment 11

17 years ago
2001091708/Linux doesn't have this bug.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 12

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.