Mouse hover over results pane in Search Messages (ctrl+shift+F) makes result rows disappear/turn white (row invalidation, screen refresh/update problem)

RESOLVED WORKSFORME

Status

Thunderbird
Search
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: Doug Hockin, Unassigned)

Tracking

17 Branch
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

Version 17.0.8.
Performed a search by selecting the top level of an email account in the left folder pane and right clicking and selecting Search Messages. Put in search criteria and click search. Get a list of search hits in the results pane at the bottom. Wave your mouse  up and down over the results pane, wave vertically parallel to any one of the columns.


Actual results:

Every so often several of the horizontal search result lines "white out" (between 1-3 lines), leaving just blank white space where the search results were. Always happens at the top of the results list. Only seems to happen when the search dialog is the default size with a results pane that is has about 6 results or slightly more. If the search dialog is made taller so that more results are showing the problem seems to go away. With above 10 results visible the problem doesn't happen.


Expected results:

Lines shouldn't have whited out as I waved over them.

Comment 1

5 years ago
Does is happen in thunderbird safe mode?
With current beta at http://www.mozilla.org/thunderbird/channel/
Flags: needinfo?(dough)
(Reporter)

Comment 2

5 years ago
Yes, happens in the current version put into safe mode.

Also happens beta version 24.0 in regular and safe mode.
Flags: needinfo?(dough)

Comment 3

5 years ago
anyone else see such issues?
Component: Untriaged → Search
Summary: Wave cursor over results pane in Search Messages and lines white out → Wave cursor over results pane in Search Messages (ctrl+shift+F) and lines white out
Oh, we've seen similar issues involving screen refresh problems before:
bug 497643
bug 378576
See Also: → bug 497643, bug 378576
Summary: Wave cursor over results pane in Search Messages (ctrl+shift+F) and lines white out → Mouse hover over results pane in Search Messages (ctrl+shift+F) makes result rows disappear/turn white (row invalidation, screen refresh/update problem)
not sure if this belongs in search component, maybe message list

Comment 6

5 years ago
The same happened to me. It seams that it has to do with the scroll bar because the result lines are few enough to fit the search results window, the symptom does not manifest.
Thunderbird version: 17.0.8
Mac OS version: 10.8.4
Confirming. I'll take a closer look at this, though it's possible this is a Gecko bug... Does this happen on Windows?
Status: UNCONFIRMED → NEW
Ever confirmed: true
I can't reproduce this on Windows XP, TB 17.
- pop3 inbox
- right-click, search messages
- subject contains: 2 searchwords like bug 123, yielding 8 results
- hover mouse vertically over search results
-> results always correctly visible no matter what I try (hovering, scrolling, selecting,right-click...)
Flags: needinfo?
(In reply to Thomas D. from comment #8)
> I can't reproduce this on Windows XP, TB 17.
> - pop3 inbox
> - right-click, search messages
> - subject contains: 2 searchwords like bug 123, yielding 8 results
where some results, like the last 2 or so, are hidden "below" due to smaller size of search dialogue, per reporter's STR
> - hover mouse vertically over search results
> -> results always correctly visible no matter what I try (hovering,
> scrolling, selecting,right-click...)
I'm seeing a similar thing since I upgraded to Thunderbird 34 Beta on Windows 7 today. As I hover over the emails in my inbox (no search required) the backgrounds will flicker, then the row I'm hovering over will show as (% occurances):
- Black text on plain white background, as if unhovered. (60%)
- Black text on light blue background (20%)
- No text on a light blue background (10%)
- No text on a white background (5%)
- Two rows will change with some combination of the above (5%)

I'm also seeing similar rendering errors in the folder list, toolbar and when composing emails.
Created attachment 8524714 [details]
Example of inbox showing rendering error
My problems goes away if I set layers.offmainthreadcomposition.enabled to false, so presumably unrelated to this original report.

Comment 13

2 years ago
Do you still see this with Thunderbird 38, when using similar settings?
(note, hardware acceleration is disabled by default at tools | addons | advanced | general )
Flags: needinfo?(eric.belfort.mattos)
Flags: needinfo?(dough)
(Reporter)

Comment 14

2 years ago
Version 45.3.0. I can't reproduce this anymore so I guess it's been fixed. Running on Mac OS 10.11.6
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

2 years ago
Flags: needinfo?(eric.belfort.mattos)
Flags: needinfo?(dough)
You need to log in before you can comment on or make changes to this bug.