Closed Bug 905699 Opened 6 years ago Closed 4 years ago

Support application preferences for cameras and mics in getUserMedia() prompts (Android)

Categories

(Firefox for Android :: General, defect)

x86_64
All
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 882145

People

(Reporter: jesup, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [getUserMedia][android-gum-])

+++ This bug was initially created as a clone of Bug #905696 +++

When implementing constraints for bug 882145, we'll need the UI to support being told that a specific device should be the default one shown to the user.  No string or other changes should occur; it's solely changing the default from the first device to a specified one. API TBD in bug 882145.

This bug is for Android; it's especially useful on mobile devices for an app to specify 'front' or 'back' cameras as the default depending on the app in question.
Whiteboard: [getUserMedia]
Whiteboard: [getUserMedia] → [getUserMedia][android-gum-]
So, basically, with the patches in bug 882145, the work needed here is:

1. Get the MediaStreamConstraintsInternal object from GetUserMediaRequest
   and pass it to GetUserMediaDevices().

2. During device enumeration, fill in the facingMode property for Android cams.
   Should be a simple mapping of front to "user" and back to "environment".

The list returned will be in priority order, so make sure the default is the first item.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 882145
You need to log in before you can comment on or make changes to this bug.