[B2G] [Settings] [STK] Some strings are untranslated

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
8 months ago

People

(Reporter: dsubramanian, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 790856 [details]
screenshot of strings untranslated in STK

Description:
The user sees few strings on the STK options in English and not in the local language set. 

Prerequisite: 
1) Have a SIM card in the device (for example; Mundo Oi)
2) Set the language other than English (Spanish)

Repro Steps:
1) Updated Leo Build ID: 20130813041202
2) Go to Settings 
3) Scroll down to Operator Services and tap on STK icon (for example; Mundo Oi)
4) Observe all the categories displayed

Actual:
The user sees untranslated strings on the STK Menu - "Videos, Chat, Agenda, Email & IM" and "OK" button on banners

Expected:
The user sees translated strings on the STK Menu in the local language selected

Environmental Variables
Build ID: 20130813041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/36bbc5943448
Gaia: df57dcec720493bedff4601499d78c147ad7d253
Platform Version: 18.1
RIL Version: 01.01.00.019.190 

Notes:
Repro frequency: 100%
See attached: Screenshot
(Reporter)

Comment 1

5 years ago
Created attachment 790857 [details]
screenshot for ok button untranslated

Comment 2

5 years ago
Please be more careful about CCing people, none of them have anything to do with this bug.

Note, OK is OK in French, so that in itself is not a bug.
(Reporter)

Comment 3

5 years ago
(In reply to Axel Hecht [:Pike] from comment #2)
> Please be more careful about CCing people, none of them have anything to do
> with this bug.
> 
> Note, OK is OK in French, so that in itself is not a bug.

Axel, 

Thanks for pointing it out to me about the "OK" button. I realize that it appears the same in French. However, there are other strings that aren't translated. Please see screenshot for more info.

I CCed Localizers as the STK menu options were in English. This issue is found in Polski, Ceština, Nederlanders, Pу́сский, ελληνικά, Slovenčina, Română, Brazilian Portuguese, Magyar, Deutsch, Spanish, Türkçe, Hrvatska, српски, Catalan and Srpski.
(Reporter)

Comment 4

5 years ago
This is a follow up of bug https://bugzilla.mozilla.org/show_bug.cgi?id=901449

Comment 5

5 years ago
If it happens in many localizations, it's unlikely an l10n problem, unCCing tons of folks.

The screenshot shows strings that aren't provided by our localizers, thus we can't fix 'em on our side.

No idea who'd be able to nail down where those strings are coming from.

PS: I'm not convinced they're wrong, too.
I didn't understand what's wrong...

If the issue is about the options under the STK menu, those strings are provided by carrier, not by Gaia or FXOS

Comment 7

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.