xpinstall.enabled firefox 23

RESOLVED DUPLICATE of bug 815120

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 815120
4 years ago
4 years ago

People

(Reporter: Cedric, Unassigned)

Tracking

23 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130803215302

Steps to reproduce:

in firefox 23 i'm able to install extensions, but in the config i have set the xpinstall.enabled to false.


Actual results:

Extension is installed, even when xpinstall.enabled is set to false


Expected results:

Installation should be refused

Comment 1

4 years ago
Dupe of bug 815120?
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit
How are you installing them?
Works for me.

STR Used:

1. Set xpinstall.enabled = false (if the pref is not existing, create it)
2. Go to addons.mozilla.org and select an addon that you want to install (in Tools->Add-ons add-ons section will not be displayed as long pref is set to false)
3. Try to install the addon selected in step 2
4. A pop-up will be displayed saying that Software instalation is currently disabled. Click to enable.

Tested  on Windows 7 x64 and Ubuntu 13.04 x86 using latest nightly 26. BuildID:20130827030201
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 4

4 years ago
I'm not sure he used this way to install the add-on, but likely the file mozilla.cfg.
Flags: needinfo?(cedric)
(Reporter)

Comment 5

4 years ago
Hi, i'm sending my firefox.cfg

lockPref("network.proxy.type", 5);
lockPref("browser.startup.homepage", "about:home");
lockPref("browser.startup.page", 1);
lockPref("browser.download.manager.showWhenStarting", true);
lockPref("browser.download.manager.closeWhenDone", false);
lockPref("browser.download.manger.retention", 1);
lockPref("browser.shell.checkDefaultBrowser", false);
lockPref("browser.rights.3.shown", true);
lockPref("signon.rememberSignons", false);
lockPref("signon.prefillForms", false);
lockPref("plugin.default_plugin_disabled", false);
lockPref("plugins.hide_infobar_for_missing_plugin", true);
lockPref("plugins.hide_infobar_for_outdated_plugin", true);
lockPref("pdfjs.disabled", false);
lockPref("xpinstall.enabled",false);

To install the addon without message, i did this:

tools  --> add-ons --> i  then searched for an addon. When you try to install it, there is no error message.
Flags: needinfo?(cedric)

Comment 6

4 years ago
So my comment #1 was right. Thanks for the reply.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 815120
You need to log in before you can comment on or make changes to this bug.