Closed Bug 905854 Opened 6 years ago Closed 6 years ago

The browser console shortcut is broken from Scratchpad

Categories

(DevTools :: Scratchpad, defect, P3)

defect

Tracking

(firefox24 unaffected, firefox25+ fixed, firefox26+ fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox24 --- unaffected
firefox25 + fixed
firefox26 + fixed

People

(Reporter: bbenvie, Assigned: bbenvie)

Details

Attachments

(1 file, 1 obsolete file)

ctrl/cmd+shift+j in Scratchpad throws the error "TypeError: this.browserWindow.HUDConsoleUI is undefined @ chrome://browser/content/devtools/scratchpad.js:1181".
Attached patch bug-905854.patch (obsolete) — Splinter Review
Fix and new test to verify the functionality works.
Assignee: nobody → bbenvie
Status: NEW → ASSIGNED
Attachment #791017 - Flags: review?(rcampbell)
This is caused by bug 877262. Brandon, can you please also ask for aurora approval? Thanks for the bug report and patch.
Comment on attachment 791017 [details] [diff] [review]
bug-905854.patch

Review of attachment 791017 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/devtools/scratchpad/test/browser_scratchpad_open_error_console.js
@@ +11,5 @@
> +    gBrowser.selectedBrowser.removeEventListener("load", onLoad, true);
> +    openScratchpad(runTests);
> +  }, true);
> +
> +  content.location = "data:text/html;charset=utf8,test Scratchpad." + 

trailing space.
Attachment #791017 - Flags: review?(rcampbell) → review+
Attached patch bug-905854.patchSplinter Review
[Approval Request Comment]
Bug caused by bug #: 877262
User impact if declined: browser error console hotkey continues to be broken
Testing completed (on m-c, etc.): tryserver
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #791017 - Attachment is obsolete: true
Attachment #792322 - Flags: review+
Attachment #792322 - Flags: approval-mozilla-aurora?
Attachment #792322 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Target Milestone: --- → Firefox 26
Target Milestone: Firefox 26 → Firefox 25
Target milestone tracks m-c landings. Status flags track branch uplifts. Also, you don't need to worry about doing the uplift yourself if you don't want. It happens to be a service offered by your faithful sheriff crew as well :)
Target Milestone: Firefox 25 → Firefox 26
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #7)
> Target milestone tracks m-c landings. Status flags track branch uplifts.
> Also, you don't need to worry about doing the uplift yourself if you don't
> want. It happens to be a service offered by your faithful sheriff crew as
> well :)

Oops. Good to know, thanks!
This hasn't landed on trunk yet.
Target Milestone: Firefox 26 → ---
fx-team landing: https://hg.mozilla.org/integration/fx-team/rev/cb165f8a2f8b
Target Milestone: --- → Firefox 26
Crap I accidentally changed the flags back.
Target Milestone: Firefox 26 → Firefox 25
lol, just stop :)
Target Milestone: Firefox 25 → ---
*failboat*
https://hg.mozilla.org/mozilla-central/rev/cb165f8a2f8b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.