Closed Bug 905890 Opened 11 years ago Closed 9 years ago

[Dialer] The device does not display any emergency number by default

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(tracking-b2g:backlog)

RESOLVED WORKSFORME
tracking-b2g backlog

People

(Reporter: leo.bugzilla.gaia, Unassigned)

References

Details

(Whiteboard: [TD-44064])

1. Title : The device does not display any emergency number by default
2. Precondition : 
3. Tester's Action : Power ON the handset >> Enter screen of input pin code >> Emergency call >> Check the behavior.
4. Detailed Symptom : The handset does not display any emergency number by default
5. Expected : The device should display at least one emergency number by default
6. Reproducibility: Y
1) Frequency Rate : 100%
7. Gaia Master/v1-train : Reproduce
8. Personal email id : promise09th@gmail.com
Whiteboard: [TD-44064]
Product team: Can you confirm if this is the expected behaviour for v1.1?  Is this a new feature request?
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(ffos-product)
Wilfred, can you confirm?
Flags: needinfo?(ffos-product)
I am not understanding the exact issue here: 
Is the failure that the device does not display an emergency number in the PIN entry screen? Or is it that you have to close the PIN entry screen before you can dial an emergency number?

Displaying an emergency phone number on a screen may be difficult given different countries have different emergency phone numbers. Perhaps something of a more generic display to click on to dial a predefined (regional) emergency number.

From the current behavior I see the following:

Power on device - unlock device - user prompted for PIN - close the PIN entry screen by pressing the x on top left - open dialer - close again the PIN entry screen on top left of screen - then dial an emergency number

This sounds like a very long winded way to dial an emergency number in case of emergency.

User should be able to make an emergency call very quickly without having to go through this number of screens to make an emergency call.
Flags: needinfo?(wmathanaraj) → needinfo?(leo.bugzilla.gaia)
blocking-b2g: leo? → koi?
(In reply to Leo from comment #0)
> 1. Title : The device does not display any emergency number by default
> 2. Precondition : 
> 3. Tester's Action : Power ON the handset >> Enter screen of input pin code
> >> Emergency call >> Check the behavior.
> 4. Detailed Symptom : The handset does not display any emergency number by
> default
> 5. Expected : The device should display at least one emergency number by
> default
> 6. Reproducibility: Y
> 1) Frequency Rate : 100%
> 7. Gaia Master/v1-train : Reproduce
> 8. Personal email id : promise09th@gmail.com


I read this as the anticipated behavior is

1) precondition: phone has pin code lock enabled
2) user wakes the phone 
3) on the pin code screen user selects 'emergency call'
4) dialer is launched with emergency number pre-populating the dialer, (but the bug is that it currently it does not)

...I don't believe at step 4) that this is a bug ...or even desirable behavior for the following reasons:

1) With all the test phones and SIMs i have lying around non of them pre-populate the dialer with an emergency number when the 'emergency number' option is selected on the locked home screen

2) How do we know which 'emergency' number the user wishes to dial? 
2.1) some countries have more than one to choose from
2.2) what do we do in situations where the user is in a different country to the country they are usually in?

if in point 2) we attempt to pre-populate the dialer with an emergency number we actually bring more risk to the user or the person they are trying to assist than assistance. This is because they firstly have to recognize that the number in the dialer is not the one they want, which increases their cognitive loading (which in an emergency situation will already be running high) and also we increase their risk of error as we introduce the possibility of them dialing the wrong number (the one in the dialer instead of the one they should be using) - putting further emotional/cognitive strain on the user... If the user recognizes the offered emergency number is incorrect before we dial it we then slow down the time they take to contact the emergency services by forcing them to delete the number and dial a new one.

This might all seem not much of a problem when read from the comfort of your desk, but in an emergency situation we should do everything we can not to confuse, block or introduce more pressure to the already distressed user ...and every second counts 

From a safety PoV I would totally advise against perpetuating the dialer.
add to backlog 891754
blocking-b2g: koi? → ---
blocking-b2g: --- → backlog
blocking-b2g: backlog → ---
Should be working for a while.
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(leo.bugzilla.gaia)
Keywords: verifyme
Resolution: --- → WORKSFORME
Based on the information in Comment #4, this feature is behaving appropriately on the latest Flame and Aries 2.5 Master builds.
The Emergency Call screen is accessible from the Lockscreen with a Passcode enabled, but is not pre-populated with an emergency number.
Removing verifyme keyword.

Environmental Variables:
Device: Aries 2.5
BuildID: 20150904191331
Gaia: 03be7d8918bed58c92a40bba211bbbc97a0e516a
Gecko: 538ccb262ec9f022b198d5fbe57a9c99c7eee9b7
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 43.0a1 (2.5) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0

Environmental Variables:
Device: Flame 2.5
BuildID: 20150904030224
Gaia: d7385b79e68d4ad662cacf810506e9ee53345d23
Gecko: 7f987c38bd3e5ac9a834981e85378bdb02338e9d
Gonk: c4779d6da0f85894b1f78f0351b43f2949e8decd
Version: 43.0a1 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:43.0) Gecko/43.0 Firefox/43.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
You need to log in before you can comment on or make changes to this bug.