[Buri]Fail to customize the URL of APP "movistar"

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(blocking-b2g:leo+)

Details

(Whiteboard: [NPOTB])

Attachments

(1 attachment)

48.46 KB, image/jpeg
Details
(Reporter)

Description

5 years ago
AU_LINUX_GECKO_ICS_STRAWBERRY.01.01.00.019.184
 Firefox os  v1.1
 Mozilla build ID:20130806071254
 
 +++ This bug was initially created as a clone of Bug #491472 +++
 PROBLEM DESCRIPTION:
 
 Enter movistar with Colombia sim card.
 The url is for Venezuela.
 
 EXPECTED BEHAVIOUR:
 
 The url should be http://www.movistar.com.co URL.
 
 ++++++++++ end of initial bug #491472 description ++++++++++
 
 		
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:

Updated

5 years ago
Summary: [Buri]Change URL to 4012A → [Buri]Fail to customize the URL of APP "movistar"
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 791113 [details]
Image1

Comment 3

5 years ago
In configuration.json, 
    "mcc" : 734
while in launcher.js,
    var currentMCC = conn.voice.network.mcc;
    if (this.configurations[i].mcc === currentMCC)
since the type is different, the condition will always be false.
blocking-b2g: --- → leo?
Flags: needinfo?(kward)
blocking-b2g: leo? → leo+

Updated

5 years ago
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Whiteboard: [NPOTB]
Version: unspecified → Trunk

Updated

5 years ago
Blocks: 871237
(In reply to buri.blff from comment #3)
> while in launcher.js,
>     var currentMCC = conn.voice.network.mcc;
>     if (this.configurations[i].mcc === currentMCC)
> since the type is different, the condition will always be false.

I don't see anything like that in the current approved version on Marketplace

Comment 5

5 years ago
(In reply to Andrew Williamson [:eviljeff] from comment #4)
> (In reply to buri.blff from comment #3)
> > while in launcher.js,
> >     var currentMCC = conn.voice.network.mcc;
> >     if (this.configurations[i].mcc === currentMCC)
> > since the type is different, the condition will always be false.
> 
> I don't see anything like that in the current approved version on Marketplace

We got the movistar app from bug 871191, and never be noticed to update?
(In reply to ying.tan from comment #5)
> (In reply to Andrew Williamson [:eviljeff] from comment #4)
> > (In reply to buri.blff from comment #3)
> > > while in launcher.js,
> > >     var currentMCC = conn.voice.network.mcc;
> > >     if (this.configurations[i].mcc === currentMCC)
> > > since the type is different, the condition will always be false.
> > 
> > I don't see anything like that in the current approved version on Marketplace
> 
> We got the movistar app from bug 871191, 

https://marketplace.firefox.com/app/mi-movistar-3/

> and never be noticed to update?

I don't know how that's all supposed to work.
Adding more people in CC to track the issue.
ni? Simon may help
Flags: needinfo?(simon.callan)
Reporter, actually, did you refer to the correct bug 902307 for v1.1?
Flags: needinfo?(sync-1)
The Mi Movistar app should be taken from the Marketplace. Daniel Coloma can help here
Flags: needinfo?(simon.callan)

Comment 11

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #9)
> Reporter, actually, did you refer to the correct bug 902307 for v1.1?

Thanks Joe, when I create this bug, the app is from bug 871191,
so I think this bug can be closed here.
Flags: needinfo?(sync-1)
close bug per comment 11
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID

Updated

5 years ago
No longer blocks: 871237

Comment 13

5 years ago
updated Mi Movistar Latam (app ID 457462) was updated and loaded on V1.1 devices.
Flags: needinfo?(kward)
You need to log in before you can comment on or make changes to this bug.