[B2G][Helix][Gaia][chengchangying]When the device is chargring,the device powers off.

RESOLVED INVALID

Status

Firefox OS
General
P2
normal
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; Tablet PC 2.0; aff-kingsoft-ciba)

Steps to reproduce:

1、put the 3.3V battery into the device and the charger is connected;

2、the device boot into poweroff charging,and then press the power key;

3、enter into home screen,the battery level is 100%(note:it  is  normal)and then becomes 0%.


Actual results:

In step3,When the battery level becomes 0%(AUTO_SHUTDOWN_LEVEL maro set in gaia),the device power off immediately.


Expected results:

When the device is charging,even if the battery is below AUTO_SHUTDOWN_LEVEL ,the device dose't power off.While the device is diarging,the deveice should power off normally.
(Reporter)

Updated

5 years ago
Severity: normal → critical
OS: All → Gonk (Firefox OS)
Priority: -- → P1
Hardware: All → ARM
Duplicate of this bug: 905923
(Reporter)

Updated

5 years ago
blocking-b2g: --- → hd?
(Reporter)

Updated

5 years ago
Severity: critical → blocker
Priority: P1 → P2
Marco, is this our current design or is there a problem with this behaviour?
Flags: needinfo?(mchen)

Comment 3

5 years ago
Hi,

I can image one concern if we didn't shutdown the device when battery is 0% and in charging.

Concern:
  If the charging is from SDP (500ms), then it may be lower then device's power consumption. This will cause device shutdown even we plugged a charger into device.
Flags: needinfo?(mchen)
(Reporter)

Comment 4

5 years ago
Marco,from the power consumption test result, the concern that you imaged is not a problem.Maybe my bug is not clear.We want the scheme is as follows:

1、when the battery is absence,the device can power up and then never power off by connect with chager or usb;

2、the battery level is below AUTO_SHUTDOWN_LEVEL (the maro set in gaia),the device not power off when the device connect with charger or usb.

About the scheme,as the other words,the device can work on the above two scenarios.In gaia layer, power off the device only according to the battery level,so we need add the anther two contions -------wherther the is the battery absence and is the device charging?
hd- as low user impact, occurs only when battery is at 0%.
blocking-b2g: hd? → ---
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Updated

5 years ago
Severity: blocker → normal
You need to log in before you can comment on or make changes to this bug.