[km] Test failure "The all tabs popup should have been opened" in /testBackgroundTabScrolling.js

RESOLVED WORKSFORME

Status

P4
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: cosmin-malutan, Unassigned)

Tracking

unspecified

Firefox Tracking Flags

(firefox23 wontfix, firefox24 wontfix)

Details

(Whiteboard: [mozmill-test-failure], URL)

(Reporter)

Description

5 years ago
Heappend on yesterday on Windows xp (x86) with Release km:
http://mozmill-release.blargon7.com/#/functional/report/b7ef1fb3d9703aeaf2c46e07d2e51b47
I couldn't reproduce it locally.
(Reporter)

Updated

5 years ago
status-firefox23: --- → affected
Summary: Test failure "The all tabs popup should have been opened" in /testBackgroundTabScrolling.js → [km] Test failure "The all tabs popup should have been opened" in /testBackgroundTabScrolling.js
Whiteboard: [mozmill-test-failure]

Updated

5 years ago
status-firefox24: --- → affected
Priority: -- → P3

Comment 1

5 years ago
I cannot reproduce this locally.

Comment 2

5 years ago
We fail at line 88 when we wait for the state of the "allTabsPopup" element to become 'open':
http://hg.mozilla.org/qa/mozmill-tests/file/eed4d1de6f98/tests/functional/testTabbedBrowsing/testBackgroundTabScrolling.js#l88

Dumps show that there is a transitory state "showing" between "closed" (default) and "open". By starving the system of resources I managed to slow it down enough to fail with Timeout error but I wasn't able to reproduce this bug.
Priority: P3 → P4

Comment 3

5 years ago
Haven't been able to locally reproduce yet but I noticed we had this failure on Macs too so I have updated the platform to All.

http://mozmill-ondemand.blargon7.com/#/functional/report/3c3cd991de01b704f3f65783a1edbe5d
OS: Windows XP → All
Hardware: x86 → All

Comment 4

5 years ago
This hasn't failed in about 7 weeks, and we've ran the [km] locale multiple times.
Given that and because it only failed only 23 and 24 (and we'll release 25 early next week),
lets close it. 

Please reopen if it fails on other branches.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-firefox23: affected → wontfix
status-firefox24: affected → wontfix
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.