Closed Bug 906025 Opened 6 years ago Closed 6 years ago

[responsive mode] vertical resizer moves incorrectly after rotate

Categories

(DevTools :: Responsive Design Mode, defect)

25 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox25 verified, firefox26 verified)

VERIFIED FIXED
Firefox 26
Tracking Status
firefox25 --- verified
firefox26 --- verified

People

(Reporter: andreldm1989, Assigned: andreldm1989)

Details

Attachments

(1 file)

Attached patch patch-fix-rotateSplinter Review
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130730113002

Steps to reproduce:

Use the vertical resizer and then rotate.


Actual results:

The vertical resizer goes to a incorrect position.


Expected results:

The vertical resizer should stay centered.
Component: Untriaged → Developer Tools: Responsive Mode
I can't reproduce. Can you reproduce in Firefox Aurora and Firefox Nightly?
Ok - I see what the issue is. A rotate right after a resize does move the handle correctly.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Keywords: qawanted
Comment on attachment 791259 [details] [diff] [review]
patch-fix-rotate

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 778174
User impact if declined: "rotate"  button doesn't work properly
Testing completed (on m-c, etc.): locally
Risk to taking this patch (and alternatives if risky): low
String or IDL/UUID changes made by this patch: none
Attachment #791259 - Attachment is patch: true
Attachment #791259 - Flags: review+
Attachment #791259 - Flags: approval-mozilla-beta?
In comment 2: s/does/doesn't
(In reply to Paul Rouget [:paul] from comment #3)
> Comment on attachment 791259 [details] [diff] [review]
> patch-fix-rotate
> 
> [Approval Request Comment]
> Bug caused by (feature/regressing bug #): bug 778174
> User impact if declined: "rotate"  button doesn't work properly
> Testing completed (on m-c, etc.): locally
> Risk to taking this patch (and alternatives if risky): low
> String or IDL/UUID changes made by this patch: none

Looks like Fx25 is affected here given 778174 landed in 25.Not sure why this would be needed on beta, hence switching the approval nom to aurora.Feel free to renom if anything was understood wrong.
Comment on attachment 791259 [details] [diff] [review]
patch-fix-rotate

[Triage Comment]
Approving the low risk patch on aurora as this is a fallout from Bug 778174
Attachment #791259 - Flags: approval-mozilla-beta? → approval-mozilla-aurora+
Assignee: nobody → andreldm1989
https://hg.mozilla.org/mozilla-central/rev/c1a70c464572
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
I confirm the fix is verified on FF 25b2 using Windows 7 x64
Verified Fixed on Latest Aurora too.

OS: Windows 7 x64
Build ID: 20131009004001

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Status: RESOLVED → VERIFIED
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.