checkbox to download ALL mail from pop3

RESOLVED INCOMPLETE

Status

--
enhancement
RESOLVED INCOMPLETE
18 years ago
10 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.2) Gecko/20010712
BuildID:    2001071209

There should be a checkbox under "Leave messages on server" saying something
like "Download only new messages" so that you can re-download previously
downloaded messages.  Currently it appears that if you check "Leave messages
..." but not "Delete when deleted locally" then download your mail there is no
way to subsequently cause those messages to be removed from the server.

Reproducible: Always
Steps to Reproduce:
1. Check "Leave messages on server" but not "Delete when deleted locally"
2. Download messages
3. Un-check "Leave messages"
4. Attempt to re-download those messages so as to remove from server

Actual Results:  Mozilla reports "There are no new messages on the server"

Expected Results:  Old messages downloaded then deleted from server.

If someone wants to use a pop3 account to receive mail at several pc's by making
use of "Leave messages on server" they may eventually end up with a lot of
messages they are unable to remove from the server.  5MB free accounts will
begin to fill up.

Comment 1

18 years ago
Reporter,

When you create a new profile and check 'leave messages on the server' a copy of 
every message that you have on the server is left on the server as well as 
downloaded too. 
If you do not want to keep these messages on the server then create a new 
profile and uncheck 'leave messages on the server' so all the messages will get 
downloaded to your hard disk and no messages are left on the  server.  

As you mentioned in your steps below if your trying to accomplish this with one 
profile it is not going to work.  If you say first leave mssgs on the server and 
went and downloaded the mail ofcourse those 10 mails that you downloaded will be 
on the server. Onwards in the same profile if you go and uncheck the option then 
messages from 11 to what ever will not be on the server. But the first 10 will 
be on the server.  If you want to get rid of the first 10 mssgs then create a 
new account and uncheck the pref 'leave mssgs on the server' and download those 
10 mssgs and they will be out of the server.

This is not a bug.    



(Reporter)

Comment 2

18 years ago
Sheela,
I do this with Pegasus Mail (a very good free email client) and I only have one
profile.  There is a checkbox which says "Download only unread mail" which I can
uncheck to get all of my mail including previously downloaded messages.  Of
course Pegasus also allows you to examine message headers without downloading
and select them for deletion from the server.  This would be a nice addition,
but the checkbox would be sufficient.  I would like to switch to Mozilla
completely for my email due to it's very good IMAP client.

Comment 3

18 years ago
This is a request for enhancement based on reporters comments. 
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
QA Contact: sheelar → esther
mass re-assign.
Assignee: naving → sspitzer
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
(Reporter)

Comment 6

12 years ago
My gosh I had forgotten about this.  I don't even use POP3 any more and don't care a bit about this.  I'm willing to stipulate that this will never be fixed (assuming it hasn't been) and am there for marking it WONTFIX.  Somoeone else can open another one if they care about it.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Comment 7

11 years ago
wontfix is reserved for developers. opting for INCOMPLETE
Resolution: WONTFIX → INCOMPLETE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.