No glass effect (Aero) under Windows x64 in FF 26 (latest update)

RESOLVED DUPLICATE of bug 905680

Status

()

RESOLVED DUPLICATE of bug 905680
5 years ago
5 years ago

People

(Reporter: luca892, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 791399 [details]
theme.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130816030205

Steps to reproduce:

Installing last update.


Actual results:

The Aero disappeared, tried on another computer and i've got the same result.
(Reporter)

Updated

5 years ago
Hardware: x86 → x86_64
(Reporter)

Comment 1

5 years ago
Created attachment 791406 [details]
Immagine.png

Updated

5 years ago
Summary: theme → No main menu list under Windows in FF 26

Comment 2

5 years ago
The main menu is supposed to be hidden by default on Windows.  You can show it temporarily by pressing Alt or unhide it by right clicking on an empty part of the tab strip and checking the Menu Bar option:

https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars
https://support.mozilla.org/en-US/kb/display-firefox-button-menu-instead-menu-toolbar

luca892, could you please try either of those options and report back if they work?
(Reporter)

Comment 3

5 years ago
No, this is not the problem, i try to explain it again. 

The 2nd screenshot that i have uploaded, it's to show that there is a white menu item that there shouldnt be (Bookmark, History, "empty space"). 

The 1st one instead is about the Aero (glass effect of windows 7) isnt enabled. You can see that it's enabled on windows and i'm going to upload another screen to let you see what do i mean with the next sentence.

Aero is enabled correctly for the settings windows, but not on main window.
(Reporter)

Comment 4

5 years ago
Created attachment 791447 [details]
aero.png
(Reporter)

Updated

5 years ago
Summary: No main menu list under Windows in FF 26 → No glass effect (Aero) under Windows x64 in FF 26 (latest update)

Comment 5

5 years ago
This is an issue in Windows 8 as well, it shows the controls exactly like it does in the "bad" screenshots rather than using Windows 8's default theme. Essentially, the top of the main FF window (where tabs appear) looks as if the Aero effect was disabled, and even looks like that on Windows 8.

Comment 6

5 years ago
https://bugzilla.mozilla.org/show_bug.cgi?id=900875

This looks like it might be related, appears to be the only thing to have touched files that might've made this happen recently.

That would be these 2 changesets:
http://hg.mozilla.org/mozilla-central/rev/3f00d003742c
http://hg.mozilla.org/mozilla-central/rev/533ac6b8ee38

Comment 7

5 years ago
I see, thanks for explaining.  This looks like a duplicate of bug 905680 then.  I'll mark it as a duplicate for now.  Bug 905680 was fixed 12 hours ago; I'm not sure if that fix will make it into the next Nightly or the Nightly after that, but if it's still broken a few Nightlies from now, then please reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 905680
You need to log in before you can comment on or make changes to this bug.