Add Menu button to "Customize Toolbar" library

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: roman.rellum, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20130816030205

Steps to reproduce:

Request: Could you add menu button to "Customize Toolbar" library which would have same functionality as default Firefox button (top left corner). Clicking on it would display menu frame, like Bookmarks button does:

How Firefox button looks: http://fii.cz/watqbnzm
How Bookmarks button looks: http://fii.cz/vrwyq

As you can see, I have addon which makes Firefox button movable, but it doesnt look native in the navigation panel. What Id like to see is same menu button as any other button in navigation panel (Bookmarks, Downloads, Home Page etc.) and being movable.

Ive seen your reaction to similar request that you dont want to change Firefox button because its something what differs browser from other ones. Just let the default button as it is and add another menu button to library so ppl who would prefer it being somewhere else can do it.

We will handle the rest of the job (removing default button) via addon. If you want to be perfect, you could add option to hide default Firefox button to options / or via about:config.

Updated

5 years ago
Severity: normal → enhancement
Component: Untriaged → Toolbars and Customization
Summary: Firefox menu button → Add Menu button to "Customize Toolbar" library
The Firefox Button will be gone in the near Future (Bug 863753). So this is likely WONTFIX/INVALID.
wontfix as per bug 863753
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.