Last Comment Bug 90617 - HierMenus no longer working
: HierMenus no longer working
Status: VERIFIED FIXED
[DHTML][TOOL][HIERMENU]
: dom0, regression, testcase
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: x86 All
: P1 critical
: ---
Assigned To: Bob Clary [:bc:]
: Zach Lipton [:zach]
:
Mentors:
http://www.webreference.com/dhtml/col...
: 94162 (view as bug list)
Depends on:
Blocks: 85104
  Show dependency treegraph
 
Reported: 2001-07-13 01:03 PDT by Markus Hübner
Modified: 2015-04-19 23:39 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
testcase (370 bytes, text/html)
2001-07-13 03:38 PDT, Conor Lennon
no flags Details

Description Markus Hübner 2001-07-13 01:03:12 PDT
At
http://www.webreference.com/dhtml/column56/HM4-0-13/LoadMe.html
you wil find the latest version of the HierMenus 4.0.13

This is the most widely used DHTML hierarchical menu library
and worked perfectly with Mozilla 0.9.2
Must be some kind of regression.

If you move the cursor over a blue-link then the pop-up menu appears
at the top of the browser-window instead of beside the menu-item.

There are no errors reported in the JavaScript console.
Don't know what this means to other DHTML functions, which 
could be affected by the regression.

Used build 2001071214
Comment 1 Johnny Stenback (:jst, jst@mozilla.com) 2001-07-13 02:19:01 PDT
Over to evangelism, I bet this is due to the fix that went in for bug 81290,
that fix makes mozilla work more like IE does wrt .offsetXXX (which this page
uses extensively) and now this site relies on the old broken mozilla behavior
that was fixed. Markus, that change went in on 6/29, could you test builds
around that date to verify?
Comment 2 Fabian Guisset 2001-07-13 02:27:33 PDT
Bob, I recommend marking P1 because this is a really important "dhtml" library.
jst, is there a way to tell the folks at hiermenus what changed in offset*
exactly? since they just released a new version (a few weeks ago), I doubt they
will like it not working with NS6.1
Comment 3 Bob Clary [:bc:] 2001-07-13 02:33:58 PDT
ok. 
Comment 4 Johnny Stenback (:jst, jst@mozilla.com) 2001-07-13 02:36:14 PDT
Fabian, .offsetXXX changed to match what IE returns when used on positioned
elements or children of positioned elements, i.e. offsets on an element that's a
child of a positioned element are relative to the closest positioned parent,
among other things like that...
Comment 5 Bob Clary [:bc:] 2001-07-13 02:43:52 PDT
contacted via peter.belesis@btclick.com 7/13/01
Comment 6 Conor Lennon 2001-07-13 03:38:24 PDT
Yes, the problem is due to .offsetTop and .offsetLeft.
The following html demonstrates the problem:

<html>
<body>
 <div id="test" style="left:100px;top:100px;position:absolute;">
  <div id="test2" style="position:absolute;">
   &nbsp;
  </div>
 </div>
 <script>
document.write("offsetLeft:"+document.getElementById('test2').offsetLeft+"<br>");
document.write("offsetTop: "+document.getElementById('test2').offsetTop+"<br>");
 </script>
</body>
</html>

0.9.2 displays an offsetLeft and offsetTop of 100, but Build 2001062815 displays 0
Comment 7 Conor Lennon 2001-07-13 03:38:56 PDT
Created attachment 42167 [details]
testcase
Comment 8 Bob Clary [:bc:] 2001-07-13 04:12:38 PDT
Peter replied and will be adapting the HierMenus to handle the changes in the
offsetXXX properties. But since he released a new version yesterday it will be a
few weeks before the next release.
Comment 9 Bob Clary [:bc:] 2001-07-18 06:37:17 PDT
adding as blocker to tracking bug 85104
Comment 10 Bob Clary [:bc:] 2001-08-10 18:48:11 PDT
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Comment 11 Zack Smith 2001-08-12 17:25:02 PDT
Version 4.0.14 of the HierMenus code has just been posted at the WebReference
site that addresses this issue, and web authors are encouraged to download and
update their HM code (which now works as intended for NS6.0, 6.1, and Mozilla
builds before and after 20010726). Perhaps bug 90617 should be marked as fixed,
as this is an HM issue, and not a problem with Mozilla code.
Comment 12 Zach Lipton [:zach] 2001-08-12 17:28:07 PDT
can we close this out now and recomend an upgrade to those using 
HierMenus?


Zach
Comment 13 Zach Lipton [:zach] 2001-08-12 17:28:32 PDT
oops, ignore that :)
Comment 14 Keyser Sose 2001-08-13 11:56:25 PDT
*** Bug 94162 has been marked as a duplicate of this bug. ***
Comment 15 Bob Clary [:bc:] 2001-08-15 15:27:35 PDT
Peter fixed HM, ->Fixed
Comment 16 Brant Gurganus 2002-02-27 19:47:33 PST
Verified
2002022703/WinXP

Note You need to log in before you can comment on or make changes to this bug.