Build Failure: emugen_intermediates/main.o Error 1

RESOLVED INVALID

Status

Firefox OS
GonkIntegration
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: arky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Unable to build emulator on Ubuntu 64 10.04 machine. 

sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp: In member function ‘int ApiGen::genFuncTable(const string&, ApiGen::SideType)’:
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:106:86: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:107:86: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp: In member function ‘int ApiGen::genContext(const string&, ApiGen::SideType)’:
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:138:87: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:139:87: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:166:92: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:170:54: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:162:150: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:153:100: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:150:88: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:142:87: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp: In member function ‘int ApiGen::genEntryPoints(const string&, ApiGen::SideType)’:
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:222:50: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:226:50: warning: ‘retval’ may be used uninitialized in this function [-Wuninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:228:54: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:208:88: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp: In member function ‘int ApiGen::genContextImpl(const string&, ApiGen::SideType)’:
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:738:34: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
sdk/emulator/opengl/host/tools/emugen/ApiGen.cpp:726:92: warning: ‘retval’ may be used uninitialized in this function [-Wmaybe-uninitialized]
host C++: emugen <= sdk/emulator/opengl/host/tools/emugen/EntryPoint.cpp
host C++: emugen <= sdk/emulator/opengl/host/tools/emugen/main.cpp
sdk/emulator/opengl/host/tools/emugen/main.cpp: In function ‘int main(int, char**)’:
sdk/emulator/opengl/host/tools/emugen/main.cpp:49:47: error: ‘getopt’ was not declared in this scope
sdk/emulator/opengl/host/tools/emugen/main.cpp:52:38: error: ‘optarg’ was not declared in this scope
sdk/emulator/opengl/host/tools/emugen/main.cpp:79:9: error: ‘optind’ was not declared in this scope
sdk/emulator/opengl/host/tools/emugen/main.cpp:92:45: error: ‘optind’ was not declared in this scope
make: *** [out/host/linux-x86/obj/EXECUTABLES/emugen_intermediates/main.o] Error 1

real    0m30.853s
user    0m10.944s
sys     0m3.772s

> Build failed! <

Build with |./build.sh -j1| for better messages
If all else fails, use |rm -rf objdir-gecko| to clobber gecko and |rm -rf out| to clobber everything else.
Ubuntu 10 is not supported.  Please try one of the supported configurations from https://developer.mozilla.org/en-US/docs/Mozilla/Firefox_OS/Firefox_OS_build_prerequisites
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.