Closed Bug 906262 Opened 9 years ago Closed 8 years ago

[Buri][Browser]It can not pop up save picture options while long press one picture

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect, P2)

defect

Tracking

(blocking-b2g:-, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g -
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: sync-1, Assigned: aus)

References

Details

(Whiteboard: [sprintready][systemsfe][p=1])

Attachments

(4 files)

It can not pop up save  picture options while long press one picture
 
 DEFECT DESCRIPTION:
  There is no save  picture options while long press one picture on webpage
 
  REPRODUCING PROCEDURES:
  1.launch browser->open url "image.baidu.com"->click one picture to open
  2.long press the picture,it won't pop up save picture option-->KO
  
  EXPECTED BEHAVIOUR:
  KO:It pop up save picture option while long press picture 
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
  https://moztrap.mozilla.org/manage/case/6889/
  
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
  high
  REPRODUCING RATE:
  5/5
  For FT PR, Please list reference mobile's behavior:
Clone from brother
Attached file logcat_509200.rar
Clone from brother
mark leo? since it's regression. Mozilla build ID:20130806071254
blocking-b2g: --- → leo?
Whiteboard: [sprintready]
QA, please verify if this is just the particular site, or a general regression.
Keywords: qawanted
QA Contact: dsubramanian
QA Contact: dsubramanian
QA Contact: dkumar
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/55432780
In response to comment 6, I noticed that this is a website issue. I was not able to reproduce this issue on any other website as the images open up in the same window and does not redirect the user to some other website.

Hint: Tapping on the picture takes the user to http://xiangee.baidu.com... And this is where the user does not get the option to save the picture. If tapping the picture takes the user to http://slide.net.sina.com... There will be no pop-up at all.

Steps to repro
Launch browser->open url "image.baidu.com"->click one picture to open>long press the picture,it would pop up “save image” option> cancel it >try tapping on the same picture once again it will open another window > now try long pressing the same picture the user will not get the “save image” option and will only see “open link in a new tab” option. 

Tested on Leo and Buri Moz and Com Ril
Environmental Variables
Build ID: 20130819041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/285e2afe2a3b
Gaia: 124ed9737f0f44781cb75f763468f1574f753ac0
Platform Version: 18.1
Keywords: qawanted
QA Contact: dkumar
Jason,

Please look at this issue further to test.
Flags: needinfo?(jsmith)
As far as I can see. It's really a website or Javascript dependent issue.
Same issue as of 905563, which can't open link in a new tab.
Interestingly enough, this works for me on a 8/2/2013 Leo partner build.
Flags: needinfo?(jsmith)
Sounds like I've confirmed this is a regression then. Adding regressionwindow-wanted to figure out a regression window here.
QA Contact: dkumar
Any progress?
We are unable to repro this issue on builds listed below. Let me know if you would like us to check on other builds and or a specific link to a picture that you know to be causing the issue.

If this answers the questions on a regression window let me know and we can remove the keyword.

Picture we used: http://tinyurl.com/l269dky

Base: 20130823
Buri Build ID: 20130806071254
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/a2a9b89ef5ee
Gaia: 4c1a20570e20f64782ba170c14604395c48f7381
Platform Version: 18.1
RIL Version: 01.01.00.019.180 

Base: V08o
Leo Build ID: 20130821041204
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/0c8931d85f0a
Gaia: 849cee8a3ee5a2a6f4e39183549d36c3acc05f2f
Platform Version: 18.1
RIL Version: 01.01.00.019.198 

Base: V08o
Leo Build ID: 20130802071207
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/ba71c64705e5
Gaia: 361cfb69e22c0db18e85422bb407550426138009
Platform Version: 18.1
liweijia@tcl.com - can you try to reproduce on the latest build? We can't reproduce this on the build IDs specified above.
Flags: needinfo?(liweijia)
Keywords: regression
(In reply to dkumar from comment #8)
> In response to comment 6, I noticed that this is a website issue. I was not
> able to reproduce this issue on any other website as the images open up in
> the same window and does not redirect the user to some other website.
You are right, it must be some root reason which can't save pic.
I test the sit http://tinyurl.com/l269dky, the pic can be saved. 
But for the sit http://baid.us/m9wC(case sensitive), the pic still can't be saved. we should find out the cause.
Flags: needinfo?(liweijia)
I just test FireFox for Android, I can save the image which can't be saved in 
firefox OS.
Attached image Test JPEG Picture
Using the attached JPEG image I can't reproduce this, but I can reproduce this bug directly with the image at http://baid.us/m9wC.
This is too specific an issue. Hence minus. Not a top rated app
blocking-b2g: leo? → -
Any reason why the pic in http://baid.us/m9wC Can't be saved?
But Firefox for Android can download it in http://baid.us/m9wC
?
Aus, can we close this bug now?
Flags: needinfo?(aus)
Maybe we can depend this on updating the browser to use the downloads api to perform these downloads and re-test when that lands? I'm thinking it's likely to solve this problem.
Flags: needinfo?(aus)
Depends on: 982295
I think we're also in agreement here that this is *not* an actual regression but a site-specific issue. I'm going ahead and clearing the 'regression' keyword because of this.

I'll also assign this to myself and do a simple re-test while working on 982295.
Assignee: nobody → aus
Keywords: regression
Whiteboard: [sprintready] → [sprintready][systemsfe]
Target Milestone: --- → 2.0 S1 (9may)
Target Milestone: 2.0 S1 (9may) → 2.0 S2 (23may)
Status: NEW → ASSIGNED
I can confirm that this issue will be resolved when bug 983747 and 982295 land.
Depends on: 983747
Whiteboard: [sprintready][systemsfe] → [sprintready][systemsfe][p=1]
Target Milestone: 2.0 S2 (23may) → 2.0 S3 (6june)
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
This now works as expected with bug 982295 and 983747 landing.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Attached video video of issue verify
This issue has been verified successfully on Flame v2.0 & v2.1
STR:
1. Launch Browser and go to "http://baid.us/m9wC".
2. Long press the picture.
**It will pop up the option "Save Image".
3. Go to "http://image.baidu.com".
4. Click one picture to open -> long press the picture.
**It will pop up the option "Save Image".
See attachment: verify_video.MP4
Reproducing rate: 0/5
Flame 2.0 versions:
Gaia-Rev        99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f91abc6127d9
Build-ID        20141125000201
Version         32.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141125.035023
FW-Date         Tue Nov 25 03:50:34 EST 2014
Bootloader      L1TC00011880

Flame 2.1 versions:
Gaia-Rev        1bdd49770e2cb7a7321e6202c9bf036ab5d8f200
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/db893274d9a6
Build-ID        20141125001201
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20141125.040617
FW-Date         Tue Nov 25 04:06:28 EST 2014
Bootloader      L1TC00011880
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.