Differential Testing: Different error message involving schedulegc

RESOLVED WORKSFORME

Status

()

Core
JavaScript Engine
--
major
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 2 bugs, {testcase})

Trunk
x86_64
Mac OS X
testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
try {
    for (x in a) {}
} catch (e) {}
function f() {
    schedulegc(1)
    ({
        v: (eval("eval(\"\",undefined)"))
    })
}
for (w in [/x/, /x/]) {
    try {
        new f
    } catch (e) {}
}

shows two instances of the following error on a 64-bit debug deterministic threadsafe js shell on m-c rev 8ad1e4c838c8 with --no-baseline --no-ti, but shows only one instance with only --no-baseline, only --no-ti or without any CLI arguments at all:

warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead.

Setting needinfo for jandem as previously requested. (Pass in the testcase as a CLI argument to reproduce)
Flags: needinfo?(jdemooij)
I can't reproduce this one.. Do you have another testcase maybe?
Flags: needinfo?(gary)
(Reporter)

Comment 2

5 years ago
(In reply to Jan de Mooij [:jandem] from comment #1)
> I can't reproduce this one.. Do you have another testcase maybe?

I can definitely reproduce this one on a Mac 10.8 machine.

$ ./js-dbg-64-dm-ts-darwin-8ad1e4c838c8 906285.js
906285.js:7:0 warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead.

$ ./js-dbg-64-dm-ts-darwin-8ad1e4c838c8 --no-baseline 906285.js
906285.js:7:0 warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead.

$ ./js-dbg-64-dm-ts-darwin-8ad1e4c838c8 --no-ti 906285.js
906285.js:7:0 warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead.


$ ./js-dbg-64-dm-ts-darwin-8ad1e4c838c8 --no-baseline --no-ti 906285.js
906285.js:7:0 warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead.
906285.js:7:0 warning: Support for eval(code, scopeObject) has been removed. Use |with (scopeObject) eval(code);| instead

I can try to get another testcase though, once the current outstanding differential testing error in bug 906286 is landed on m-c.
Flags: needinfo?(gary)
(Reporter)

Comment 3

5 years ago
Whatever this was, it seems to work fine by m-c rev d58fc624899c.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(jdemooij)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.