404 with mozilla.org/firefox/its-a-trap.html and mozilla.org/firefox/its-an-attack.html

RESOLVED DUPLICATE of bug 971244

Status

RESOLVED DUPLICATE of bug 971244
5 years ago
5 years ago

People

(Reporter: philip.chee, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

5 years ago
Somewhere in SafeBrowsing.jsm there are these two URLs:
http://hg.mozilla.org/mozilla-central/annotate/8ad1e4c838c8/toolkit/components/url-classifier/SafeBrowsing.jsm#l148

  addMozEntries: function() {
    // Add test entries to the DB.
    // XXX bug 779008 - this could be done by DB itself?
    const phishURL   = "mozilla.org/firefox/its-a-trap.html";
    const malwareURL = "mozilla.org/firefox/its-an-attack.html";

Both these pages are now 404. Previously you could click on Ignore and you would get to a page explaining what SafeBrowsing is about.
That's right and we have seen the same by Thursday or Friday when our Mozmill tests started to fail. This is most likely a website change given that we now redirect to a localized page given the locale of Firefox. Looks like this is work is not done yet, and causes us to end-up on a 404 page.
I've just tried with my Nightly (it) and I don't get any error on those URLs.

With curl I can get a 404 on www.mozilla.org etc. (the URLs with mozilla.org are 301).

$curl -I mozilla.org/firefox/its-an-attack.html
HTTP/1.1 301 Moved Permanently
Server: Apache
X-Backend-Server: bedrock2.webapp.phx1.mozilla.com
Vary: Accept-Encoding
Content-Type: text/html; charset=iso-8859-1
Date: Sun, 18 Aug 2013 16:53:19 GMT
Location: http://www.mozilla.org/firefox/its-an-attack.html
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Cache-Info: caching


$ curl -I http://www.mozilla.org/firefox/its-an-attack.html
HTTP/1.1 404 Not Found
Server: Apache
X-Backend-Server: bedrock2.webapp.scl3.mozilla.com
Vary: Accept-Encoding
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0, private
Content-Type: text/html; charset=UTF-8
Date: Sun, 18 Aug 2013 16:54:51 GMT
Status: 404 Not Found
Pragma: no-cache
Transfer-Encoding: chunked
Connection: Keep-Alive
X-Robots-Tag: noodp
X-Cache-Info: not cacheable; response specified "Cache-Control: no-store"

Updated

5 years ago
Component: Other → General
Depends on: 880147
Product: Websites → www.mozilla.org

Comment 3

5 years ago
Marking this as worksforme. Please re-open if this is incorrect.

The 2 URLS:

http://www.mozilla.org/firefox/its-an-attack.html
http://www.mozilla.org/firefox/its-a-trap.html 

Are "special" as they trigger in-firefox pages to load. If you load these in manner other than firefox, they should 404. For example you can load these in chrome, you should see a 404 error page.

Loading these in firefox (at this moment) they correctly display the in-firefox alerts. There may have been a problem here when the bug was filed but I am currently unable to re-produce.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

5 years ago
STR:
1. Visit http://www.mozilla.org/firefox/its-an-attack.html
2. Click "Ignore this warning"
3. See the 404 page

Whoops! What are you doing here?

Did you make a left at that last URL instead of a right? No problem. Unless you want us to deal you in, here are some tips to get you back on your way:

--------------------------

Bug 880147 and Bug 707652 need to be fixed as well.

Suggested plan of action:
1. Fix the website pages - Bug 880147
1a. Fix redirects

http://www.mozilla.org/firefox/its-a-trap.html
-> http://www.itisatrap.org/

http://www.mozilla.org/firefox/its-an-attack.html
-> http://www.itisatrap.org/its-an-attack.html

1b. Fix itisatrap.org

"www.itisatrap.org has been unusable for over a year because the pages are structured the wrong way:"

https://bugzilla.mozilla.org/show_bug.cgi?id=880147#c2
https://bugzilla.mozilla.org/show_bug.cgi?id=686731#c14

2. Fix Firefox code (url-classifier) to point to www.itisatrap.org
http://hg.mozilla.org/mozilla-central/annotate/d812f80a0f1d/toolkit/components/url-classifier/SafeBrowsing.jsm#l149
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 5

5 years ago
OK setting this as a dupe of 971244 (trying to keep things organized)

Somehow whatever pages were here, are not here anymore. So mozilla.org is redirecting to pages that do not exist and generating the 404.

By fixing the itisatrap site and updating the mozilla.org redirects users will get directed to these pages and not the 404s.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 971244
You need to log in before you can comment on or make changes to this bug.