Firefox Hangs/freezes in google forum and other sites

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: Naveen, Unassigned)

Tracking

({hang})

23 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0 (Beta/Release)
Build ID: 20130814063812

Steps to reproduce:

Tried to load all these (even loading one page results the same) pages 

http://productforums.google.com/forum/#!topic/gmail/7Jefan1-OSQ[1-25-false]

http://productforums.google.com/forum/#!topic/gmail/RRp_I76yfZE[1-25-true]

http://productforums.google.com/forum/#!topic/gmail/RRp_I76yfZE[1-25-true]

Another eg : http://www.dota2.com/store/


Actual results:

While loading them firefox froze . It would work again (while the page still loading) then again freeze , on top tab it would show "firefox not responding" or simply hangs.


Expected results:

It shouldnt do the above said and load those pages as any other normal page.

Comment 1

5 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:26.0) Gecko/20100101 Firefox/26.0

WFM with a clean profile on FF 23.0.1 (Build ID: 20130814063812) and latest Nightly (Build ID: 20130819030205) with the URLs from comment 0.

Naveen, could you please test in safe mode: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode and with a new profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles ?

Same issue?
Flags: needinfo?(naveenreloaded)
(Reporter)

Comment 2

5 years ago
Yes the same result. There is lag/freeze and micro freezes when loading multiple google forum link.

Here is the profiler screenshot 

http://i.imgur.com/aDqhFPa.png
Flags: needinfo?(naveenreloaded)
(Reporter)

Comment 3

5 years ago
here is for dota 2 store

http://i.imgur.com/lkLHtaY.png
Works for me too from MacOSX. Naveen, are you still seeing with the Firefox 24 release?  I'm tagging this bug with "hang", but I'm not sure how to proceed any further without being able to confirm the bug.
Flags: needinfo?(naveenreloaded)
Keywords: hang
(Reporter)

Comment 5

5 years ago
I am currently on FF23 stable and no plans in moving to other channels.

I am not the only here i guess http://www.reddit.com/r/firefox/comments/1khjv2/is_it_just_me_or_ff23_simply_hangs_on_loading/ 

Anyway to post any logs during this hang ?
Flags: needinfo?(naveenreloaded)
Naveen, now I am seeing it in Firefox 24. I hadn't realized I needed to load all the tabs at once. When I did that the issue was easy to see.  At first, switching tabs doesn't work while the Forum tabs seem to be loading or re-loading their content. After a minute or two, the "stutter" stops happening. 

I can't replicate the problem in Nightly (26.0a1)
Status: UNCONFIRMED → NEW
Component: Untriaged → Tabbed Browser
Ever confirmed: true
(Reporter)

Comment 7

5 years ago
thanks . I did mention it in my FP to open all these at once. If you try opening dota 2 also while trying to open google forum , the browser almost comes to an halt. Sorry for comparing , but this doesnt seem to happen on chrome. anyway good to know its reproducible.

Comment 8

5 years ago
Liz, I also can't reproduce today's nightly 64bit build on win7
(not a clean profile)

I suggest this is WFM

Naveen, you don't need to "install" firefox to test it (and thus mess up your current install).  You can download and unzip https://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-26.0a1.en-US.win32.zip and run it from the unzipped directory
Flags: needinfo?(naveenreloaded)
Flags: needinfo?(lhenry)
(Reporter)

Comment 9

5 years ago
http://i.imgur.com/0gx0TxI.jpg

same issue. 

Opening dota 2 store alone was very responsive. But when i try to open google forum , the problem occurs again.



Also is there a way to run your FF 26 without add-ons ? it seems to take all the add-ons , config of the current installation. I unzipped and ran from desktop .
Flags: needinfo?(naveenreloaded)
(Reporter)

Comment 10

5 years ago
Started a fresh profile and opened multiple links (dota store , google forum) with nightly and still it has the issue. 

http://i.imgur.com/IyIINWw.jpg

The browser starts to hang when you open multiple tabs (4-5 google forum links) + dota store site and try moving through tabs quickly. It will hang and come to an halt.

Hope its reproducible for you too.
It was reproducible in FF23 and 24. I will look for a regression window to see if we can usefully narrow down where the issue was fixed between the 24 and 26 versions.
Flags: needinfo?(lhenry)
Keywords: regressionwindow-wanted
(Reporter)

Comment 12

5 years ago
Thanks

Comment 13

4 years ago
(In reply to Liz Henry :lizzard from comment #11)
> It was reproducible in FF23 and 24. I will look for a regression window to
> see if we can usefully narrow down where the issue was fixed between the 24
> and 26 versions.

That's a lot of work, and only needed if your are desperate to find what fixed it.
At minimum, based on liz's testing it is likely that it will work for Naveen if a current version is used (you could test it yourself by downloading a zip)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.